Loading

Erreurs : « Le service de licence FLEXNet n'est pas présent » ou « La fonction flxActAppActivationSend a retourné une erreur (0,0,0) » lors de l'activation sur Mac

Date de publication: Sep 11, 2025
Description
Lorsque vous tentez d'activer une clé produit sur Tableau Desktop sur un Mac (sans utiliser LBLM), l'une des erreurs suivantes peut se produire :
 
Le service d'octroi de licence FLEXNet est absent du système.

ou
Function flxActAppActivationSend
returned error (0,0,0)
LM_TS error 0

Cause

Soit le package FLEXNet n'a pas été installé ou n'est pas lisible par l'ordinateur qui exécute Tableau Desktop, soit Tableau Desktop a été installé sur un volume qui n'est pas défini par défaut.
Résolution

Option 1 : pour Tableau Desktop 2019.3 et versions ultérieures

Procédez comme suit pour essayer de recréer le dossier FLEXnet.

  1. Fermez toutes les instances de Tableau Desktop.
  2. Depuis le bureau d'OS X Mac, appuyez sur Commande + Maj + G.
  3. Dans la boîte de dialogue Aller au dossier, saisissez : /Library/Preferences/FLEXnet Publisher/
  4. Renommez le dossier FLEXnet en ajoutant « _backup».
  5. Démarrez Tableau Desktop et activez votre clé produit.
Si cette tentative de forcer le dossier FLEXnet a être créé de nouveau ne fonctionne pas, veuillez réinstaller Tableau Desktop.  Si vous n'arrivez toujours pas à effectuer l'activation, veuillez créer un ticket auprès de l'assistance technique Tableau.

Option 2 : pour Tableau Desktop 2019.2 et versions antérieures

Sur l'ordinateur qui exécute Tableau Desktop, installez manuellement les composants d'octroi de licence FlexNet.
  1. Dans le Finder, cliquez sur Applications.
  2. Maintenez la touche Contrôle enfoncée, cliquez sur Tableau et sélectionnez Afficher le contenu du package (Show Package Contents).
  3. Double-cliquez sur Contents (Contenu), double-cliquez sur Installers (Programmes d'installation), puis double-cliquez sur Tableau FLEXNET.pkg.
  4. Suivez les instructions de l'assistant d'installation et utilisez les options par défaut.
Si Tableau Desktop est installé sur un volume secondaire ou qui n'est pas défini par défaut, déplacez manuellement FNPLicensingService vers le répertoire Root Library.
  1. Dans Finder, localisez le fichier FNPLicensingService qui se trouve dans le dossier « /Library/Application Support/FLEXnet Publisher/Service/11.16.2/ » du même volume sur lequel Tableau Desktop est installé.
  2. Copiez FNPLicensingService vers la bibliothèque racine du système, puis créez les dossiers nécessaires : /Library/Application Support/FLEXnet Publisher/Service/11.16.2/
  3. Une fois ce fichier correctement placé, lancez et activez Tableau Desktop.
Numéro d’article de la base de connaissances

001473989

 
Chargement
Salesforce Help | Article