Loading

Errori: "FLEXNet licensing service is not present" o "Function flxActAppActivationSend returned error (0,0,0)" durante l'attivazione su Mac

Data pubblicazione: Sep 11, 2025
Descrizione
Quando tenti di attivare un codice prodotto su Tableau Desktop su Mac (senza usare LBLM), potrebbe verificarsi uno dei seguenti errori:
 
The FLEXNet licensing service is not present on the system. (Il servizio di gestione licenze FLEXNet non è presente sul sistema.)

o
Function flxActAppActivationSend
returned error (0,0,0)
LM_TS error 0 (La funzione flxActAppActivationSend ha restituito un errore (0,0,0) LM_TS errore 0)

Cause

Il pacchetto FLEXNet non è stato installato o risulta non leggibile dal computer su cui è in esecuzione Tableau Desktop oppure Tableau Desktop è stato installato su un volume non predefinito.
Risoluzione

Opzione 1: Tableau Desktop 2019.3 e versioni successive

Esegui le seguenti operazioni per tentare di ricreare la cartella FLEXnet.

  1. Chiudi tutte le istanze di Tableau Desktop.
  2. Dal desktop Mac OS X, premi Comando+Maiuscole+G.
  3. Nella finestra di dialogo Go to Folder (Vai alla cartella), immetti: /Library/Preferences/FLEXnet Publisher/
  4. Rinomina la cartella FLEXnet aggiungendo '_backup'.
  5. Avvia Tableau Desktop e attiva il codice prodotto.
Se il tentativo di forzare la ri-creazione della cartella FLEXnet non riesce, reinstalla Tableau Desktop.  Se l'attivazione ancora non riesce, crea un ticket con l'Assistenza tecnica Tableau.

Opzione 2: Tableau Desktop 2019.2 e versioni precedenti

Sul computer con Tableau Desktop, installa manualmente i componenti di gestione licenza FlexNet.
  1. Nello Strumento di ricerca, fai clic su Applicazioni.
  2. Tieni premuto il tasto Control, fai clic su Tableau, quindi seleziona Mostra il contenuto del pacchetto.
  3. Fai doppio clic su Contenuti, quindi fai doppio clic su Programmi di installazione, infine sempre doppio clic su Tableau FLEXNET.pkg.
  4. Segui le istruzioni della procedura guidata di installazione e utilizza le opzioni predefinite.
Se Tableau Desktop è installato su un volume non predefinito o secondario, sposta manualmente FNPLicensingService nella directory Root Library (Libreria radice).
  1. Nel Finder, individua il file FNPLicensingService situato nella cartella "/Library/Application Support/FLEXnet Publisher/Service/11.16.2/" sullo stesso volume su cui è installato Tableau Desktop.
  2. Copia il file FNPLicensingService nella libreria radice del sistema e crea le cartelle necessarie: /Library/Application Support/FLEXnet Publisher/Service/11.16.2/
  3. Una volta posizionato correttamente quel file, lancia e attiva Tableau Desktop.
Numero articolo Knowledge

001473989

 
Caricamento
Salesforce Help | Article