Loading

Fehler "DataSourceException: No Tableau Server user found ... Unable to connect to the server" beim Aktualisieren einer extraktbasierten Arbeitsmappe

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Beim Aktualisieren einer Arbeitsmappe mit extraktbasierten, veröffentlichten Datenquellen auf Tableau Server oder Tableau Cloud tritt möglicherweise folgender Fehler auf:
 
com.tableausoftware.nativeapi.dll.DataSourceException: No Tableau Server user found. (Kein Tableau Server-Benutzer gefunden.)
class DataSourceException (Klassen-Datenquellausnahme)
Unable to connect to the server "<server name or IP address>". Check that the server is running and that you have access privileges to the requested database. (Zu dem Server "<Servername oder IP-Adresse>" kann keine Verbindung hergestellt werden. Stellen Sie sicher, dass der Server ausgeführt wird und dass Sie über Zugriffsberechtigungen für die angeforderte Datenbank verfügen.)

Cause

Der Tableau Server-Name oder die IP-Adresse hat sich geändert, und veröffentlichte Arbeitsmappen sind für die alten Verbindungsinformationen konfiguriert oder die Arbeitsmappe besitzt keine eingebetteten Anmeldeinformationen.
Lösung

Aktualisieren der Tableau Server-Datenverbindung:

  1. Überprüfen Sie den Namen bzw. die IP-Adresse von Tableau Server.
  2. Öffnen Sie die Arbeitsmappe in Tableau Desktop.
  3. Klicken Sie mit der rechten Maustaste im Bereich Daten auf den Namen der Datenquelle und wählen Sie Tableau-Datenserver > Server- und Websitepfad bearbeiten aus.
  4. Klicken Sie im Dialogfeld Tableau Server-Datenverbindung bearbeiten auf Anmeldung ändern.
  5. Geben Sie den entsprechenden Servernamen bzw. die IP-Adresse ein.
  6. Befolgen Sie die übrigen Schritte im Fenster und klicken Sie auf OK.
  7. Veröffentlichen Sie die Arbeitsmappe mit der Authentifizierung mit eingebettetem Kennwort erneut. Weitere Informationen finden Sie unter Einbetten von Kennwörtern und Authentifizierung.
Sollte das Problem nach Ausführung dieses Lösungsansatzes weiterhin bestehen, führen Sie die folgenden Schritte durch (Tableau Desktop erforderlich): 

Schritt 1: Erneutes Hinzufügen der Datenquelle

  1. Laden Sie die Arbeitsmappe von Tableau Server herunter und öffnen Sie sie mit Tableau Desktop.
  2. Klicken Sie oben im Bildschirm auf "Daten".
  3. Klicken Sie auf "Neue Datenquelle".
  4. Klicken Sie auf "Tableau Server".
  5. Wählen Sie dann die ursprüngliche Quelle der Datenquelle, die den Fehler verursacht, aus.
  6. Klicken Sie auf den Titel Ihres Arbeitsblattes.Es sollten Ihnen nun zwei Datenquellen mit demselben Namen angezeigt werden. An den Namen der neuen Datenquelle ist eine Zahl angehängt, beispielsweise "Datenquelle(2)".

Schritt 2: Ersetzen der ursprünglichen Verbindung

  1. Klicken Sie im Datenbereich mit der rechten Maustaste auf Ihre ursprüngliche Datenquelle (die erste Verbindung, die nicht funktioniert hat) und wählen Sie "Datenquelle ersetzen" aus.
  2. Stellen Sie sicher, dass die im Feld "Aktuell" aufgeführte Datenquelle der ursprünglichen schlechten Verbindung entspricht und dass die Datenquelle im Ersatzfeld der neuen Verbindung entspricht, die Sie soeben hinzugefügt haben.
  3. Klicken Sie auf "OK".
  4. Speichern Sie die Arbeitsmappe.
  5. Schließen Sie die Arbeitsmappe und öffnen Sie sie erneut.
  6. Klicken Sie mit der rechten Maustaste im Datenbereich auf die Datenquelle und zeigen Sie mit der Maus auf "Tableau-Datenserver" und "Server- und Websitepfad bearbeiten".
  7. Überprüfen Sie dann, ob die aufgeführte Server-URL korrekt ist. Wenn dies der Fall ist, klicken Sie auf "Abbrechen".
  8. Veröffentlichen Sie diese Arbeitsmappe mit der neuen Verbindung zu Tableau Server und versuchen Sie, sie erneut zu aktualisieren.
Zusätzliche Ressourcen
Wenn das Problem bei Arbeitsmappen mit eingebetteten Datenquellen auftritt, überprüfen Sie, ob der RunAs-Benutzer für Tableau Server die entsprechenden Berechtigungen besitzt. Weitere Informationen zum Festlegen aller entsprechenden RunAs-Benutzerberechtigungen finden Sie unter Als Benutzer ausführen in Tableau.
Nummer des Knowledge-Artikels

001474011

 
Laden
Salesforce Help | Article