Loading

Error "Excepción de fuente de datos: no se ha encontrado ningún usuario de Tableau Server... No se puede conectar con el servidor" al actualizar el libro de trabajo basado en una extracción

Fecha de publicación: Aug 24, 2022
Descripción
Al actualizar un libro de trabajo que contiene fuentes de datos publicadas basadas en extracciones en Tableau Server o Tableau Cloud, puede aparecer el siguiente error:
 
com.tableausoftware.nativeapi.dll.DataSourceException: No Tableau Server user found. (No se ha encontrado ningún usuario de Tableau Server).
class DataSourceException
Unable to connect to the server "<server name or IP address>". Check that the server is running and that you have access privileges to the requested database. (No se puede conectar con el servidor "<nombre del servidor o dirección IP>". Compruebe que el servidor está en ejecución y que dispone de privilegios de acceso a la base de datos solicitada).

Cause

Ha cambiado el nombre o la dirección IP de Tableau Server y los libros de trabajo publicados se han configurado con la información de conexión antigua o el libro de trabajo no tiene credenciales insertadas.
Solución

Actualizar la conexión de datos de Tableau Server:

  1. Compruebe el nombre o dirección IP de Tableau Server.
  2. Abra el libro de trabajo en Tableau Desktop.
  3. Haga clic con el botón derecho en el nombre de fuente de datos en el panel Datos y seleccione Servidor de datos de Tableau > Editar sitio y ruta del servidor.
  4. En el cuadro de diálogo Editar conexión de datos de Tableau Server, haga clic en Cambiar inicio de sesión.
  5. Escriba el nombre de servidor y dirección IP adecuados.
  6. Siga los pasos restantes en la ventana y haga clic en Aceptar.
  7. Vuelva a publicar el libro de trabajo con la autenticación de contraseña insertada. Para obtener más información, consulte Insertar contraseñas y autenticación.
Si la solución anterior no resuelve el problema, pruebe los pasos siguientes (Requiere Tableau Desktop): 

Paso 1: añadir la fuente de datos de nuevo

  1. Descargue el libro de trabajo de Tableau Server y ábralo con Tableau Desktop.
  2. Haga clic en "Datos" en la parte superior de la pantalla.
  3. Haga clic en "Nueva fuente de datos".
  4. Haga en "Tableau Server".
  5. Desde aquí, seleccione la fuente original de la fuente de datos que está causando el error.
  6. Haga clic en el título de su hoja de trabajo. Ahora debería ver dos fuentes de datos con el mismo nombre. La nueva fuente de datos tendrá un número detrás, por ejemplo "datasource(2)".

Paso 2: sustituir la conexión original

  1. Haga clic con el botón derecho del ratón en la fuente de datos original de la lista del panel Datos (la primera conexión, la que no estaba funcionando) y seleccione "Reemplazar fuente de datos".
  2. Asegúrese de que la fuente de datos incluida en el campo "Actual" es la conexión no válida original y que la fuente de datos en el campo de sustitución es la conexión nueva que acaba de añadir.
  3. Haga clic en "Aceptar".
  4. Guarde el libro de trabajo.
  5. Cierre el libro de trabajo y vuelva a abrirlo.
  6. Haga clic con el botón derecho en la fuente de datos en el panel Datos y sitúe el ratón en "Servidor de datos de Tableau" y "Editar servidor y ruta del sitio".
  7. Desde aquí, confirme que la URL del servidor incluida en la lista es correcta. Si es así, haga clic en "Cancelar".
  8. Publique este libro de trabajo con la nueva conexión a Tableau Server e intente volver a actualizarlo.
Recursos adicionales
Si los libros de trabajo con fuentes de datos insertadas experimentan este problema, compruebe que Ejecutar como usuario de Tableau Server cuenta con los permisos adecuados. Consulte Ejecutar como usuario en Tableau para obtener más información acerca de cómo establecer los permisos adecuados para Ejecutar como usuario.
Número del artículo de conocimiento

001474011

 
Cargando
Salesforce Help | Article