Loading

Errore "DataSourceException: No Tableau Server user found ... Unable to connect to the server" quando si aggiorna la cartella di lavoro basata su estrazioni

Data pubblicazione: Aug 24, 2022
Descrizione
Quando si aggiorna una cartella di lavoro contenente origini dati pubblicate e basate sulle estrazioni in Tableau Server o Tableau Cloud, potrebbe verificarsi il seguente errore:
 
com.tableausoftware.nativeapi.dll.DataSourceException: No Tableau Server user found.
class DataSourceException
Unable to connect to the server "<server name or IP address>". Check that the server is running and that you have access privileges to the requested database. (com.tableausoftware.nativeapi.dll.DataSourceException: Nessun utente di Tableau Server trovato. classe DataSourceException Impossibile connettersi al server "<nome server o indirizzo IP>". Verifica che il server sia in esecuzione e di disporre dei privilegi d'accesso al database richiesto).

Cause

Il nome o l'indirizzo IP di Tableau Server è stato modificato e le cartelle di lavoro pubblicate sono configurate per l'informazione della vecchia cartella o la cartella di lavoro non dispone di credenziali incorporate.
Risoluzione

Aggiornare la connessione dati di Tableau Server:

  1. Verifica il nome o l'indirizzo IP di Tableau Server.
  2. Apri la cartella di lavoro in Tableau Desktop.
  3. Fai clic con il pulsante destro del mouse sul nome dell'origine dati dal pannello Dati e seleziona Server di dati Tableau > Modifica percorso al sito e al server.
  4. Nella finestra di dialogo Modifica connessione dati di Tableau Server, fai clic su Modifica accesso.
  5. Immetti il nome del server o l'indirizzo IP appropriati.
  6. Segui i passaggi restanti nella finestra e fai clic su  OK.
  7. Pubblica nuovamente la cartella di lavoro avente l'autenticazione con password incorporata. Per ulteriori informazioni, vedi Incorporamento di password e autenticazione.
Se la soluzione precedente non è stata utile per risolvere il problema, prova a seguire i passaggi indicati di seguito (è necessario Tableau Desktop): 

Passaggio 1: Aggiungi nuovamente l'origine dati

  1. Scarica la cartella di lavoro da Tableau Server e aprila con Tableau Desktop.
  2. Fai clic su "Dati" nella parte superiore dello schermo.
  3. Fai clic su "Nuova origine dati".
  4. Fai clic su "Tableau Server".
  5. Da qui, seleziona l'origine originaria dell'origine dati che causa l'errore. 
  6. Fai clic sul titolo del foglio di lavoro. A questo punto dovresti visualizzare due origini dati con lo stesso nome. La nuova origine presenterà un numero dopo il nome, ad esempio "origine dati(2)".

Passaggio 2: Sostituisce la connessione originale

  1. Fai clic con il pulsante destro del mouse sull'origine dati originaria elencata nel riquadro Dati (la prima connessione, quella non funzionante) e seleziona "Sostituisci origine dati".
  2. Assicurati che l'origine dati elencata nel campo "Corrente" sia la connessione originale non corretta e che l'origine dati nel campo di sostituzione sia la nuova connessione appena aggiunta. 
  3. Fai clic su "ok".
  4. Salva la cartella di lavoro.
  5. Chiudi la cartella di lavoro e aprila nuovamente.
  6. Fai clic con il pulsante destro del mouse sull'origine dati nel riquadro Dati e passa il puntatore su "Server di dati Tableau" e "Modifica percorso al sito e al server".
  7. Da qui, conferma che l'URL elencato del server sia corretto. In tal caso, fai clic su "Annulla".
  8. Pubblica questa cartella di lavoro con la nuova connessione a Tableau Server e prova ad aggiornarla nuovamente. 
Risorse aggiuntive
Se l'errore viene riscontrato nelle cartelle di lavoro con origini dati incorporate, verifica che l'utente Esegui come di Tableau Server disponga delle autorizzazioni corrette. Per ulteriori informazioni su come impostare tutte le corrette autorizzazioni per l'utente Esegui come, vedi Utente Esegui come.
Numero articolo Knowledge

001474011

 
Caricamento
Salesforce Help | Article