Loading
Salesforce now sends email only from verified domains. Read More

Data Does Not Refresh when Using Live Excel or Text File Connection

Publish Date: Dec 24, 2025
Description

When you have a packaged workbook (.twbx) connected live to Excel or Text files and you try to refresh the data, the data might not refresh.

Cause

This behavior is by design to allow workbooks to be shared with users that do not have access to the original data source. Please see Packaged Workbooks for more information:
 

"Packaged workbooks contain the workbook along with a copy of any local file data sources and background images. The workbook is no longer linked to the original data sources and images."
 

If the original data source is a text file, then Tableau Desktop will create a shadow copy of the text file in the TableauTemp folder. If the connection to the text file is live, then Tableau Desktop will change the file path to the TableauTemp folder.

 

  • Note: this change will not show until the workbook is saved, closed, and reopened.
Resolution
Option 1: Edit the connection to point to the original data source

If saving the work as a *.twbx file, extract the connection to the text file first. If the connection to the text file should be live, then always save the workbook as a *.twb file.
  1. In Tableau Desktop, select Data > <data source name> > Edit Data Source. This will navigate to the Data Source tab for this data source.
  2. Select Data > <data source name> > Edit Connection...
User-added image
  • Note: The file path will include the TableauTemp folder rather than the original location of the file
        3. In Windows Explorer, navigate to the original data source file, and then click Open.
        4. In Tableau Desktop, select the Extract radio button.
        5. Navigate to a worksheet tab in the workbook, which will prompt Tableau Desktop to create the extract.
        6. To refresh data, under Data, right-click the data source, and then select Extract > Refresh.

Option 2: Close the program where the text file is open and attempt refreshing again

Option 3: Create a new connection to replace the old connection
  1. Click Data at the top toolbar, and select New Data Source > Excel
  2. Select the correct file, and connect. This will create a second connection to the same file.
  3. Navigate to any sheet that uses the old data connection.
  4. Replace the old connection with the new connection. For detailed directions, see Replace Data Sources
Additional Resources
If the file path in Option 1 > Step 2 is not pointing to TableauTemp, then there may be another underlying issues. For other possible scenarios, please see the other articles below:

Data Not Refreshing When Using SharePoint-Based Excel Data Sources
Error "an error occurred while connecting to Tableau Data Extract" Using .twbx With Live Connections to Excel or Text Files
 
Knowledge Article Number

001474030

 
Loading
Salesforce Help | Article