Loading

Text- oder CSV-Dateidatenquelle gibt nicht alle Zeilen zurück

Veröffentlichungsdatum: Jul 18, 2023
Beschreibung
Wenn Sie eine Verbindung zu einer Textdatei oder CSV-Datenquelle herstellen, ist die von Tableau Desktop gemeldete Anzahl Datensätze möglicherweise geringer als die Anzahl Zeilen in der Text- oder CSV-Datei.

Cause

Mögliche Ursache 1
Die Datei wird mit einer Kodierung gespeichert, die nicht mit der Zeichensatzeinstellung der Verbindung übereinstimmt, oder der Textqualifizierer wurde falsch festgelegt.

Mögliche Ursache 2
Es sind Werte vorhanden, die das Feldtrennzeichen einschließen (z. B.: Komma wird als Trennzeichen verwendet, aber die Zahl wird als 123,456 angezeigt).
Lösung
Lösung für mögliche Ursache 1 (siehe zugrunde liegende Ursache)
 

Option 1: 

Speichern Sie die CSV-Datei mit ANSI-, OEM-, UTF-8- oder UTF-16-Kodierung.

Option 2:

  1. Klicken Sie in Tableau Desktop mit der rechten Maustaste auf die Datenquelle im Datenbereich und wählen Sie Datenquelle bearbeiten... aus.
  2. Klicken Sie im Verknüpfungsbereich auf den Dropdown-Pfeil am Tabellennamen und wählen Sie dann Textdateieigenschaften aus.
  3. Wählen Sie für den Zeichensatz die für die CSV-Datei verwendete Kodierung aus. ​
  4. Wählen Sie für den Textqualifizierer das Zeichen aus, das zum Markieren des Textanfangs und -endes verwendet wird.
Lösung für mögliche Ursache 2

Stellen Sie sicher, dass das Feldtrennzeichen nicht im Datenwert angezeigt wird.
 
 
Zusätzliche Ressourcen


Über diesen Artikel diskutieren... Feedback-Forum
Nummer des Knowledge-Artikels

001474069

 
Laden
Salesforce Help | Article