Loading

La source de données du fichier texte ou CSV ne renvoie pas toutes les lignes

Date de publication: Jul 18, 2023
Description
Lorsque vous vous connectez à un fichier texte ou à une source de données CSV, le nombre d'enregistrements indiqués par Tableau Desktop peut être inférieur au nombre de lignes dans le fichier texte ou CSV.

Cause

Cause possible 1
Le fichier est enregistré avec un encodage qui ne correspond pas au paramètre de jeu de caractères de la connexion, ou le qualificateur de texte n'est pas défini correctement.

Cause possible 2
Des valeurs incluent un séparateur de champ (par exemple : une virgule est utilisée comme séparateur, mais le nombre s'affiche sous la forme 123,456)
Résolution
Solution pour la cause possible 1 (reportez-vous à la cause du problème)
 

Option 1 : 

Enregistrez le fichier CSV avec l'encodage ANSI, OEM, UTF-8 ou UTF-16.

Option 2 :

  1. Dans Tableau Desktop, faites un clic droit sur la source de données dans le volet Données et sélectionnez Modifier la source de données...
  2. Dans la zone de liaison, cliquez sur la flèche bas dans le nom de la table, puis sélectionnez Propriétés du fichier texte
  3. Dans Jeu de caractères, sélectionnez l'encodage utilisé pour le fichier CSV. ​
  4. Dans Qualificateur de texte, sélectionnez le caractère utilisé pour marquer le début et la fin du texte
Solution pour la cause possible 2

Assurez-vous que le séparateur de champ ne s'affiche pas dans la valeur de donnée
 
 
Ressources supplémentaires


Discuter de cet article... Forum de commentaires
Numéro d’article de la base de connaissances

001474069

 
Chargement
Salesforce Help | Article