Loading

Error "Peer certificate cannot be authenticated with given CA certificates (online.tableausoftware.com)"

Fecha de publicación: Aug 24, 2022
Descripción

Al intentar conectarse a Tableau Cloud desde Tableau Desktop, puede aparecer el siguiente error:

Cannot connect to Tableau Server. Please check the server name and port and try again.
Internet communication error: Error "Peer certificate cannot be authenticated with given CA certificates (online.tableausoftware.com)" (Error "No se puede autenticar el certificado de pares con estos certificados CA")

 
Este error también puede producirse al conectarse a una fuente de datos basada en API (como Salesforce, Google Analytics...).

Cause

Los nuevos certificados SSL con un cifrado más seguro se implementaron en direcciones URL de Tableau, lo cual ayuda a prevenir futuros ataques y vulnerabilidades. Estas actualizaciones tenían que cumplir con un plazo de compatibilidad con Microsoft SHA-256.

Solución

Trabaje con el personal de TI para asegurarse de que los certificados raíz del equipo están actualizados y son compatibles con SHA-256, y compruebe si las últimas actualizaciones del sistema operativo están aplicadas.

Windows

En muchos casos, puede resolver este problema aplicando una actualización de certificado raíz desde Microsoft.

  1. Abra Internet Explorer y vaya a la actualización del certificado raíz en el Catálogo de Microsoft Update.

    Nota: El catálogo de actualizaciones solo es accesible desde Internet Explorer.

  2. Busque la actualización que corresponda a su sistema operativo y a la cantidad de bits asociada, y luego haga clic en Añadir, a la derecha.
  3. Haga clic en ver cesta, en la esquina superior derecha de la página.
  4. Confirme que aparece la actualización correcta en la lista y haga clic en el botón Descargar en la esquina superior derecha. Vaya a la ubicación donde quiere descargar la actualización, selecciónela y haga clic en Continuar.

    Cuando finalice la descarga, haga clic en Cerrar.

  5. En el equipo, busque el archivo descargado, haga clic en él con el botón derecho y seleccione Ejecutar como administrador.

    Nota: La instalación es silenciosa y no avisará cuando se haya completado.

  6. Cuando se complete la instalación de la actualización, abra Tableau Desktop e inicie sesión en Tableau Cloud.
Si el problema no se resuelve al actualizar el sistema con los pasos anteriores, puede que tenga que instalar el certificado Thawte SHA-256. Vea los pasos siguientes y consulte con el personal interno de TI: 
  1. Visite https://www.thawte.com/roots/
  2. Descargue el certificado "Thawte Primary Root CA – G3 (SHA256)"
    1. Haga clic con el botón derecho en Descargar raíz ahora  
    2. Seleccione Guardar destino como... 
    3. Guarde el archivo en la máquina local 
  3. Busque el archivo y cámbiele el nombre para que incluya la extensión de archivo .crt 
    1. Nota: Convertir el archivo a .crt le permitirá instalar el certificado en la máquina de Windows 
  4. Seleccione para permitir el cambio de la extensión de archivo 
  5. Abra el archivo y seleccione Instalar certificado  
  6. Seleccione Siguiente y complete el asistente para importar certificados

Mac OS X

Si surge este error en un Mac, es posible que el equipo no tenga el certificado raíz Thawte Primary Root CA - G3 o que este no sea de confianza. Si esta es la causa del error, como hemos explicado anteriormente, asegúrese de que el sistema está actualizado.

Para buscar las actualizaciones del sistema:

  1. En el menú de Apple, vaya a Preferencias del sistema.
  2. Según la versión de OS X, seleccione Actualizaciones del sistema o App Store.
  3. (Opcional pero recomendado) Seleccione Buscar actualizaciones automáticamente.
  4. Descargue las actualizaciones que el sistema indique que están disponibles, especialmente las de seguridad.

Si al actualizar el sistema a través de las preferencias del sistema no se resuelve el problema, puede que haya que instalar el certificado Thawte Primary Root CA - G3 manualmente. Vea Vínculos relacionados y consulte con el personal interno de TI.

Recursos adicionales

Si el problema persiste tras actualizar el certificado raíz del equipo, contacte con el soporte técnico de Tableau Cloud.

Número del artículo de conocimiento

001474087

 
Cargando
Salesforce Help | Article