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Erreur "Peer certificate cannot be authenticated with given CA certificates (online.tableausoftware.com)"

Date de publication: Aug 24, 2022
Description

Lorsque vous tentez de vous connecter à Tableau Cloud depuis Tableau Desktop, l'erreur suivante peut se produire :

Cannot connect to Tableau Server. Please check the server name and port and try again.
Internet communication error: Peer certificate cannot be authenticated with given CA certificates (online.tableausoftware.com). (Impossible de se connecter à Tableau Server. Vérifiez le nom du serveur et le port, puis réessayez. Erreur de communication Internet : Le certificat d'homologue ne peut pas être authentifié avec les certificats CA données) (online.tableausoftware.com).)

 
Cette erreur peut également se produire lorsque vous vous connectez à une source de données basée sur une API (par exemple Salesforce, Google Analytics...).

Cause

Les nouveaux certificats SSL présentant un cryptage renforcé ont été implémentés dans les URL de Tableau afin d'empêcher de futures attaques et vulnérabilités. Ces mises à jour devaient être conformes avec une échéance de compatibilité future avec Microsoft SHA-256.

Résolution

Contactez votre équipe informatique interne pour vérifier que les certificats racines de votre ordinateur sont à jour et compatibles avec SHA-256, et que les mises à jour système les plus récentes ont été appliquées.

Windows

Dans de nombreux cas, vous pouvez résoudre ce problème en appliquant une mise à jour de certificat racine de Microsoft.

  1. Ouvrez Internet Explorer et accédez à la mise à jour des certificats racine dans le Catalogue Microsoft Update.

    Remarque : Update Catalog est uniquement accessible via Internet Explorer.

  2. Trouvez la mise à jour qui correspond à votre système d'exploitation et sa version de bits, puis cliquez sur Add (Ajouter) sur la droite.
  3. Cliquez sur view basket (afficher le panier) dans le coin supérieur droit de la page.
  4. Vérifiez que la mise à jour correcte figure dans la liste, puis cliquez sur le bouton Download (Télécharger) en haut à droite. Recherchez et sélectionnez l'emplacement où vous voulez télécharger la mise à jour, puis cliquez sur Continue (Continuer).

    Une fois le téléchargement terminé, cliquez sur Fermer.

  5. Sur votre ordinateur, recherchez le fichier téléchargé, faites un clic droit dessus, puis sélectionnez Exécuter en tant qu'administrateur.

    Remarque : L'installation est silencieuse et n'affiche aucune indication lorsqu'elle est terminée.

  6. Une fois l'installation de la mise à jour terminée, ouvrez Tableau Desktop et connectez-vous à Tableau Cloud.
Si la mise à jour du système à l'aide de la procédure ci-dessus ne résout pas le problème, il peut être nécessaire d'installer le certificat Thawte SHA-256. Consultez les étapes ci-dessous et adressez-vous à votre équipe informatique interne :
  1. Accédez au site https://www.thawte.com/roots/
  2. Téléchargez le certificat "Thawte Primary Root CA – G3 (SHA256)"
    1. Faites un clic droit sur Download Root Now (Télécharger le certificat racine maintenant)  
    2. Sélectionnez Save Target As... (Enregistrer la cible sous)
    3. Enregistrez le fichier sur votre ordinateur local
  3. Localisez et renommez le fichier de manière à inclure l'extension de fichier .crt
    1. Remarque : La conversion du fichier en .crt vous permet d'installer le certificat sur votre ordinateur Windows
  4. Sélectionnez Yes (Oui) pour autoriser le changement de l'extension de fichier
  5. Ouvrez le fichier et sélectionnez Install Certificate (Installer le certificat)  
  6. Sélectionnez Next (Suivant) et terminez l'assistant Importation de certificat.

Mac OS X

Si vous rencontrez cette erreur sur un Mac, il se peut qu'il manque le certificat racine Thawte Primary Root CA - G3 sur l'ordinateur, ou que le certificat ne soit pas approuvé. Si cela provoque l'erreur, comme indiqué ci-dessus, assurez-vous que le système est à jour.

Pour rechercher les mises à jour système :

  1. Dans le menu Apple, ouvrez Préférences Système.
  2. Selon la version d'OS X, sélectionnez Mises à jour système ou App Store.
  3. (Facultatif mais facultatif) Sélectionnez Rechercher automatiquement les mises à jour.
  4. Téléchargez les mises à jour que le système indique comme disponibles, en particulier les mises à jour de sécurité.

Si la mise à jour du système via les Préférences Système ne résout pas le problème, il se peut que vous deviez mettre à jour l'autorité de certification Thawte Primary Root CA - G3 manuellement.Reportez-vous aux Liens connexes, et adressez-vous à votre équipe informatique interne.

Ressources supplémentaires

Si le problème persiste après la mise à niveau du certificat racine de votre ordinateur, contactez le support de Tableau Cloud.

Numéro d’article de la base de connaissances

001474087

 
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