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Impossibile generare log di Tableau Server completi

Data pubblicazione: Dec 9, 2022
Descrizione
Durante la raccolta dei file di log di Tableau Server per una data specifica, i file di log potrebbero essere incompleti e contenere solo:
  • config folder
  • tabsvc.yml
  • netstat-info.txt
  • buildversion.txt
  • wgserver.checksum
Il prompt dei comandi potrebbe mostrare messaggi come:

zip error: Nothing to do! (errore zip: nessuna operazione da eseguire!) 
*** zip had either errors or warnings. (zip con errori o avvisi.)
*** Some files may not have been added from D:/Program Files/Tableau/Tableau Server/logs (Alcuni file potrebbero non essere stati aggiunti da D:/Program Files/Tableau/Tableau Server/logs)
 

Cause

Il comando ziplog è stato eseguito per una data futura: non esistono ancora file di log per tale data.

Il comando ziplog è stato eseguito in un prompt dei comandi di Windows o in un terminale di Linux con privilegi insufficienti.
Risoluzione

Opzione 1 
Specifica una data nel passato.


Opzione 2
Il prompt dei comandi/terminale non dispone di privilegi sufficienti per eseguire il comando ziplog. Esegui il prompt dei comandi di Windows o il terminale di Linux come amministratore.

Windows:

  1. Fai clic con il pulsante destro del mouse sul menu Start e seleziona Prompt dei comandi (amministratore)
  2. Prova a eseguire il comando
  3. Se non funziona, fai clic su Start
  4. Digita cmd
  5. Fai clic con il pulsante destro del mouse su CMD e seleziona Esegui come utente o Esegui come altro utente
  6. Immetti le credenziali di Tableau Server

Linux:

 
  1. Esegui il comando ziplog
    sudo tsm maintenance ziplogs [opzioni] [opzioni globali]
    
  2. Ricevi la richiesta di inserire la password di amministratore
Risorse aggiuntive
Da Tableau 2021.4, quando si specificano le date e l'ora, viene aggiunta l'opzione oraria (H:mm) in tsm maintenance ziplogs.
 
Numero articolo Knowledge

001474116

 
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