Loading

完全な Tableau Server ログを生成できない

公開日: Dec 9, 2022
説明
特定の日付の Tableau Server ログ ファイルを収集すると、ログ ファイルが不完全で、次のデータのみが含まれている場合があります。
  • config フォルダー
  • tabsvc.yml
  • netstat-info.txt
  • buildversion.txt
  • wgserver.checksum
コマンド プロンプトには、次のようなメッセージが表示されます。

zip error: Nothing to do! (zip エラー: 処理なし!) 
*** zip had either errors or warnings. (zip にエラーまたは警告がありました。)
*** Some files may not have been added from D:/Program Files/Tableau/Tableau Server/logs (一部のファイルは、D:/Program Files/Tableau/Tableau Server/logs から追加されませんでした)
 

Cause

未来の日付に対して ziplogs コマンドが実行され、その日付のログ ファイルがまだありませんでした。

ziplog コマンドが不十分な権限で Windows コマンド プロンプトまたは Linux ターミナルで実行されました。
解決策

オプション 1
過去の日付を指定します。


オプション 2
コマンド プロンプト / ターミナルには、ziplog を実行するための十分な権限がありません。管理者として Windows コマンド プロンプトまたは Linux ターミナルを実行します。

Windows:

  1. [スタート] メニューを右クリックし、[コマンド プロンプト] (管理者) を選択します。
  2. コマンドを実行してみます。
  3. コマンドが機能しない場合は、[スタート] をクリックします。
  4. 「cmd」と入力します。
  5. [CMD] を右クリックし、[ユーザーとして実行] または [別のユーザーとして実行] を選択します。
  6. Tableau Server の認証資格情報を入力します。

Linux:

 
  1. 次の ziplog コマンドを実行します。
    sudo tsm maintenance ziplogs [options] [global options]
    
  2. プロンプトを受け取り、管理者パスワードを入力します。
その他のリソース
Tableau 2021.4 から、日付/時刻を指定するときの時刻オプション (H:mm) が tsm maintenance ziplogs に追加されました。
 
ナレッジ記事番号

001474116

 
読み込み中
Salesforce Help | Article