Loading

Error "DataSourceException: Database error 0x80040E4D: Authorization Failed" Refreshing SAP BW Extract

Data pubblicazione: Mar 28, 2025
Descrizione
When using a scheduled task to refresh a SAP BW database, the extract might fail with the following error:

com.tableausoftware.nativeapi.dll.DataSourceException: Database error 0x80040E4D: Authorization failed. 

Cause

Tableau Server is unable to connect to SAP BW due to issues with accessing the SAPLogon.ini file.
Risoluzione

Verify that all computers running Tableau Server are able to connect to SAP BW:

Option 1

  1. Ensure that Tableau Server is configured to use a Run As User account. For more information, see Run As User.
  2. On the computer that is running Tableau Server, sign in to Windows as the Run As User.
  3. Run SAP Logon and create the SAP BW server connection.

Option 2

Use this option if the Run As User account is set up as a service account and does not have Windows sign-in permissions.

  1. On the computer that is running Tableau Server, sign in to Windows as an administrator.
  2. The steps vary depending on if you are using an older version of the connector that uses the .ini file for configuration, or the newer version that uses XML.
    1. If using a SAP GUI Tools version prior to 7.40: Create an SAPLOGON_INI_FILE system environment variable and set its value to the file path (file name included) of a valid saplogon.ini file (for example, C:\SAP\saplogon.ini).
    2. If using a SAP GUI Tools version later than 7.40: ensure that SAPUILandscape.xml and SAPUILandscapeGlobal.xml are accessible by the Run-as User, and connection information is correct. More information may be found at: https://help.tableau.com/current/pro/desktop/en-us/examples_sapbw.htm
  3. Run tsm restart to restart Tableau Server. 
Risorse aggiuntive

Numero articolo Knowledge

001474129

 
Caricamento
Salesforce Help | Article