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Some Salesforce Fields Missing when Connecting to Data from Tableau

Publiceringsdatum: Nov 18, 2025
Beskrivning
When connecting to a Salesforce.com table in Tableau Desktop, expected fields might not appear.

Cause

The issue can be caused by one of the following: 
  1. The field exists in a different table than originally thought. Fields in Salesforce.com can be referenced across several tables.
  2. The field is defined as a formula in Salesforce.com
  3. The field is defined as Long Text Area in Salesforce.com
  4. Large text/string type fields, specially formatted text/string fields(such as the "Body" field of the "FeedItem" object ), binary/BLOB/CLOB type fields, and basically all non-primitive data types are excluded from fetch by Tableau
Lösning

Depending on the specific field and object, the issue may be resolved in one or all of the following ways: 

Option 1

Create a connection to the correct table, where the desired fields are located. This might require using a join or creating a custom connection. For more information, see Connecting to Salesforce Data Source.

Option 2

If the field type is defined as a formula in Salesforce.com, it will not import due to limitations with the Salesforce API. You must connect to all of the tables that contain the fields in the formula and use that data to create a calculated field.

Option 3

If the field is defined as a Long Text Area, you may contact the Salesforce administrator to see if it's possible to create a second field for Text field and pragmatically copy contents from the original Long Text field to the new Text field as a possible workaround.
Note: “Long Text Area” fields are only excluded if their defined maximum length in Salesforce exceeds 4096 characters.
This limit applies to the field’s definition (capacity), regardless of the actual number of characters stored in the field for any given record.  For more information, see Errors during extract.

Knowledge-artikelnummer

001474139

 
Laddar
Salesforce Help | Article