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SAML-Anmeldung schlägt mit Fehler "Ungültiger Benutzername oder ungültiges Kennwort" und SAML-Fehler "Registrierung der vertrauenden Seite nicht gefunden" wird in den Vizportal-Protokollen angezeigt

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

SAML-Authentifizierung schlägt mit der Fehlermeldung "Invalid username or password" (Ungültiger Benutzername oder ungültiges Kennwort) fehl. Außerdem wird der SAML-Fehler "Relying Party Registration not found" (Registrierung der vertrauenden Seite nicht gefunden) in der Datei vizportal-<n>.log angezeigt.

Beispiel für Fehler:

  • Im Webbrowser:

Unable to Sign In (Anmeldung nicht möglich)
"Invalid username or password" (Ungültiger Benutzername oder ungültiges Kennwort)

 

  • In der Datei vizportal-<n>.log:

// ziplogs\node1\vizportal_0.20204.21.0217.12032796448277247282360\logs\vizportal_node1-0.log.2021-04-06
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML Authentication Failed, the SAML Response from the IdP was not valid: [relying_party_registration_not_found] Relying Party Registration not found Relying Party Registration not found (SAML-Authentifizierung fehlgeschlagen, die SAML-Antwort des IdP war nicht gültig: [relying_party_registration_not_found] Registrierung der vertrauenden Seite nicht gefunden - Registrierung der vertrauenden Seite nicht gefunden).
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html (SAML-Anmeldung fehlgeschlagen, Benutzer wird zu /#/error/signin/16?redirectPath=/wg/saml/logout/index.html weitergeleitet)

 

Cause

  • Die EntityID des IdP (SAML-Aussteller) in der SAML-Antwort stimmt nicht mit der EntityID in den Metadaten des IdP überein, die in Tableau Server importiert wurden.
  • Da Tableau Server eine SAML-Antwort empfängt und anhand der Einstellungen überprüft, ob sie gültig ist, handelt es sich hierbei um ein Problem mit der Metadatenübereinstimmung eines IdP. Weitere Informationen finden Sie im SAML-Schema (Schritt 4 ~ Schritt 5) in SAML.
Lösung
Stellen Sie sicher, das der Wert der EntityID des IdP in der Metadatendatei und der Wert, der im Vizportal-Protokoll ausgegeben wird, übereinstimmen.
Wenn sie nicht übereinstimmen, ändern und korrigieren Sie die Metadatendatei, laden Sie die Einstellungsdatei erneut hoch und starten Sie Tableau Server neu, wie in der Online-Hilfe unten beschrieben.

1. EntityID des IdP in den Metadaten des IdP, importiert in Tableau Server. Weitere Informationen finden Sie unter "Kehren Sie zur TSM-Weboberfläche zurück. Geben Sie bei Schritt 4 in der Grafikoberfläche den Pfad zur IdP-Metadatendatei ein und klicken Sie dann auf "Datei auswählen"". 
Beispiel für IdP-Metadaten:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<EntityDescriptor entityID="<EntityID des IdP>" xmlns="urn:oasis:names:tc:SAML:2.0:metadata">
    <IDPSSODescriptor WantAuthnRequestsSigned="false" protocolSupportEnumeration="urn:oasis:names:tc:SAML:2.0:protocol">

2. EntityID des IdP (SAML-Aussteller), die eine echte SAML-Antwort zurückgegeben hat
Beachten Sie, dass die SAML-Antwort nur in der Debug-Ebene vizportal-<n>.log angezeigt wird.
Beispiel für vizportal-<n>.log auf Debug-Ebene:
2021-05-17 08:42:52.306 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Processing the SAML Authentication attempt. (SAML-Authentifizierungsversuch wird verarbeitet.)
2021-05-17 08:42:52.307 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.services.SAMLMessageLogger - <samlp:Response xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" ID="s2e7228b43916e3a98d52152d64179587c1cda4dd1" InResponseTo="ARQ53ed66d-b501-4ccb-8dbc-cea3cd99b1c3" Version="2.0" IssueInstant="2021-05-16T23:42:52Z" Destination="<Tableau Server URL>/wg/saml/SSO/index.html"><saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion"><EntityID des IdP></saml:Issuer><samlp:Status xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol">
...
2021-05-17 08:42:52.398 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLIdPMessageProcessor - Calculated relying party as <EntityID des IdP> (Vertrauende Seite wurde als <EntityID des IdP> berechnet.)
2021-05-17 08:42:52.399 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Authentication request failed: Saml2AuthenticationException{error=[relying_party_registration_not_found] Relying Party Registration not found} (Authentifizierungsanfrage fehlgeschlagen: Saml2AuthenticationException{error=[relying_party_registration_not_found] Registrierung der vertrauenden Seite nicht gefunden})
org.springframework.security.saml2.provider.service.authentication.Saml2AuthenticationException: Relying Party Registration not found (Registrierung der vertrauenden Seite nicht gefunden)
Zusätzliche Ressourcen
  • Um SAML-bezogene Details zu protokollieren, muss vizportal.log.level auf die Debug-Ebene gesetzt werden:
1. tsm configuration set -k vizportal.log.level -v debug
2. tsm pending-changes apply
3. Versuchen Sie die SAML-Anmeldung.
4. Prüfen Sie die Datei vizportal_node1-0.log.
  • Windows: %PROGRAMDATA%\Tableau\Tableau Server\data\tabsvc\logs\vizportal\vizportal_node1-0.log
  • Linux: /var/opt/tableau/tableau_server/data/tabsvc/logs/vizportal/vizportal_node1-0.log
 
  • Führen Sie nach der Fehlerbehebung den folgenden Befehl aus, um das vizportal.log.level auf den Standardwert zurückzusetzen:
1. tsm configuration set -k vizportal.log.level -d 
2. tsm pending-changes apply
Nummer des Knowledge-Artikels

001474173

 
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