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Error de inicio de sesión de SAML "Invalid username or password" y error de SAML "Relying Party Registration not found" en los registros de Vizportal

Fecha de publicación: Dec 9, 2022
Descripción

Se produce una falla en la autenticación de SAML y aparece el mensaje de error "Invalid username or password" (Usuario o contraseña no válidos). Además, se muestra el error de SAML "Relying Party Registration not found" (No se encontró el registro de la parte dependiente) en el registro vizportal-<n>.log.

Ejemplos de errores:

  • En el navegador web:

Unable to Sign In (No se puede iniciar sesión)
Invalid username or password (Nombre de usuario o contraseña no válidos)

 

  • En vizportal-<n>.log:

// ziplogs\node1\vizportal_0.20204.21.0217.12032796448277247282360\logs\vizportal_node1-0.log.2021-04-06
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML Authentication Failed, the SAML Response from the IdP was not valid: [relying_party_registration_not_found] Relying Party Registration not found Relying Party Registration not found. (Error en la autenticación de SAML; la respuesta de SAML del IdP no es válida)
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html
(Error de inicio de sesión de SAML; se redirecciona al usuario)

 

Cause

  • La clase entityID del IdP (emisor de SAML) en la respuesta de SAML no coincide con la clase entityID en los metadatos del IdP que se importaron en Tableau Server.
  • Dado que Tableau Server recibe y verifica si es una respuesta de SAML válida en función de la configuración, se trata de un problema de no coincidencia de los metadatos del IdP. Para obtener más información, consulte el flujo de SAML (pasos 4 y 5) en SAML.
Solución
Compruebe que el valor de entityID del IdP en el archivo de metadatos y el resultado del valor en el registro vizportal coincidan.
Si no coinciden, modifique y corrija el archivo de metadatos, vuelva a cargar el archivo de configuración y reinicie Tableau Server como se describe en la Ayuda en línea a continuación.

1. entityID del IdP en los metadatos del IdP importados a Tableau Server. Para obtener más información, consulte "Regresar a la interfaz de usuario web de TSM. Para el paso 4 de la GUI, introduzca la ruta al archivo de metadatos del IdP y haga clic en Seleccionar archivo". 
Ejemplo de metadatos del IdP:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<EntityDescriptor entityID="<IdP's entityID>" xmlns="urn:oasis:names:tc:SAML:2.0:metadata">
    <IDPSSODescriptor WantAuthnRequestsSigned="false" protocolSupportEnumeration="urn:oasis:names:tc:SAML:2.0:protocol">

2. entityID del IdP (emisor de SAML) que efectivamente devolvió la respuesta de SAML
Tenga en cuenta que la respuesta de SAML solo se muestra a nivel de la depuración en vizportal-<n>.log.
Ejemplo de vizportal-<n>.log a nivel de la depuración:
2021-05-17 08:42:52.306 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Processing the SAML Authentication attempt.
2021-05-17 08:42:52.307 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.services.SAMLMessageLogger - <samlp:Response xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" ID="s2e7228b43916e3a98d52152d64179587c1cda4dd1" InResponseTo="ARQ53ed66d-b501-4ccb-8dbc-cea3cd99b1c3" Version="2.0" IssueInstant="2021-05-16T23:42:52Z" Destination="<Tableau Server URL>/wg/saml/SSO/index.html"><saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion"><IdP's entityID></saml:Issuer><samlp:Status xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol">
...
2021-05-17 08:42:52.398 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLIdPMessageProcessor - Calculated relying party as <IdP's entityID>
2021-05-17 08:42:52.399 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Authentication request failed: Saml2AuthenticationException{error=[relying_party_registration_not_found] Relying Party Registration not found}
org.springframework.security.saml2.provider.service.authentication.Saml2AuthenticationException: Relying Party Registration not found
Recursos adicionales
  • Para registrar los detalles relacionados con SAML, debe configurarse vizportal.log.level a nivel de la depuración:
1. tsm configuration set -k vizportal.log.level -v debug
2. tsm pending-changes apply
3. Intente iniciar sesión con SAML.
4. Compruebe el archivo vizportal_node1-0.log.
  • Windows: %PROGRAMDATA%\Tableau\Tableau Server\data\tabsvc\logs\vizportal\vizportal_node1-0.log
  • Linux: /var/opt/tableau/tableau_server/data/tabsvc/logs/vizportal/vizportal_node1-0.log
 
  • Después de solucionar el problema, ejecute el siguiente comando para restablecer vizportal.log.level al valor predeterminado:
1. tsm configuration set -k vizportal.log.level -d 
2. tsm pending-changes apply
Número del artículo de conocimiento

001474173

 
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