Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

エラー "Invalid username or password" (ユーザー名またはパスワードが無効です) で SAML ログインに失敗し、SAML エラー "Relying Party Registration not found" (証明書利用者の登録が見つかりません) が Vizportal のログに記録される

公開日: Dec 9, 2022
説明

SAML 認証に失敗して "ユーザー名またはパスワードが無効です" というエラー メッセージが表示されます。また、"証明書利用者の登録が見つかりません" という SAML エラーが vizportal-<n>.log に出力されます。

エラーの例:

  • Web ブラウザー:

Unable to Sign In (サインインできません)
Invalid username or password (ユーザー名またはパスワードが無効です)

 

  • vizportal-<n>.log:

// ziplogs\node1\vizportal_0.20204.21.0217.12032796448277247282360\logs\vizportal_node1-0.log.2021-04-06
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML Authentication Failed, the SAML Response from the IdP was not valid (SAML 認証に失敗しました。IdP からの SAML 応答が有効ではありませんでした): [relying_party_registration_not_found] Relying Party Registration not found Relying Party Registration not found. (証明書利用者の登録が見つかりません)
2021-04-06 17:30:41.689 +0900 (-,-,-,YGwcMcSejrfeFts3UbUqBQAAAAU,62006ec2-59b4-4f06-8e36-2d696be10884) catalina-exec-5 auth_saml: INFO  com.tableausoftware.samlauthentication.handlers.SAMLAuthenticationFailureHandler - SAML login failed, redirecting user to /#/error/signin/16?redirectPath=/wg/saml/logout/index.html (SAML ログインに失敗しました。ユーザーを ... にリダイレクトしています)

 

Cause

  • SAML 応答内の IdP entityID (SAML 発行者) が、Tableau Server にインポートされた IdP のメタデータの entityID と一致しません。
  • Tableau Server では、受信した SAML 応答の有効性は設定に基づいて検証されるため、これは IdP のメタデータ不一致の問題です。詳細については、「SAML」の SAML フロー (ステップ 4 ~ ステップ 5) を参照してください。
解決策
IdP の entityID について、メタデータ ファイル内の値と、vizportal のログに出力された値が一致していることを確認します。
一致していない場合は、メタデータ ファイルを修正し、設定ファイルをもう一度アップロードし、以下のオンライン ヘルプの説明に従って Tableau Server を再起動します。

1. Tableau Server にインポートされた IdP のメタデータ内の IdP entityID。詳細については、「TSM Web UI に戻ります。GUI のステップ 4 では、IdP メタデータ ファイルへのパスを入力し、次に [ファイルの選択] をクリックします」を参照してください。 
IdP のメタデータの例:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<EntityDescriptor entityID="<IdP's entityID>" xmlns="urn:oasis:names:tc:SAML:2.0:metadata">
    <IDPSSODescriptor WantAuthnRequestsSigned="false" protocolSupportEnumeration="urn:oasis:names:tc:SAML:2.0:protocol">

2. 実際に SAML 応答を返した IdP entityID (SAML 発行者)
SAML 応答は debug レベルの vizportal-<n>.log にしか出力されないことに注意してください。
debug レベルの vizportal-<n>.log の例:
2021-05-17 08:42:52.306 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Processing the SAML Authentication attempt. (SAML 認証試行を処理しています。)
2021-05-17 08:42:52.307 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.services.SAMLMessageLogger - <samlp:Response xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" ID="s2e7228b43916e3a98d52152d64179587c1cda4dd1" InResponseTo="ARQ53ed66d-b501-4ccb-8dbc-cea3cd99b1c3" Version="2.0" IssueInstant="2021-05-16T23:42:52Z" Destination="<Tableau Server URL>/wg/saml/SSO/index.html"><saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion"><IdP's entityID></saml:Issuer><samlp:Status xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol">
...
2021-05-17 08:42:52.398 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLIdPMessageProcessor - Calculated relying party as <IdP's entityID> (<IdP's entityID> として計算された証明書利用者)
2021-05-17 08:42:52.399 +0900 (-,-,-,YKGt-N5GvHne@nSFd230EwAAABI,e1fc5233-17e3-4c48-bf11-9080c4b15031) catalina-exec-4 auth_saml: DEBUG com.tableausoftware.samlauthentication.filters.SAMLAuthenticationProcessingFilter - Authentication request failed: Saml2AuthenticationException{error=[relying_party_registration_not_found] Relying Party Registration not found} (証明書利用者の登録が見つかりません)
org.springframework.security.saml2.provider.service.authentication.Saml2AuthenticationException: Relying Party Registration not found (証明書利用者の登録が見つかりません)
その他のリソース
  • SAML 関連の詳細をログに記録するには、vizportal.log.level を debug レベルに設定する必要があります。
1. tsm configuration set -k vizportal.log.level -v debug
2. tsm pending-changes apply
3. SAML ログインを試みます。
4. vizportal_node1-0.log を確認します。
  • Windows: %PROGRAMDATA%\Tableau\Tableau Server\data\tabsvc\logs\vizportal\vizportal_node1-0.log
  • Linux: /var/opt/tableau/tableau_server/data/tabsvc/logs/vizportal/vizportal_node1-0.log
 
  • トラブルシューティングが終了したら、次のコマンドを実行して vizportal.log.level をデフォルトにリセットします。
1. tsm configuration set -k vizportal.log.level -d 
2. tsm pending-changes apply
ナレッジ記事番号

001474173

 
読み込み中
Salesforce Help | Article