Loading

TSM-Befehle schlagen nach dem Neustart des Server-Hosts fehl mit "Verbindung zum Server konnte nicht hergestellt werden. Stellen Sie sicher, dass Tableau Server ausgeführt wird, und versuchen Sie es erneut."

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung
Auf Oracle 7 Linux-Systemen schlagen TSM-Befehle beim Neustart des Hostrechners von Tableau Server nach der Aktualisierung der FUSE-Bibliothek im Betriebssystem mit dem folgenden Fehler fehl:
 
"Could not connect to TSM Controller." (Verbindung zum TSM-Controller nicht möglich)
"Could not connect to server. Make sure that Tableau Server is running and try again." (Verbindung zum Server konnte nicht hergestellt werden. Stellen Sie sicher, dass Tableau Server ausgeführt wird, und versuchen Sie es erneut.) 

Tableau Server kann nach einiger Zeit wieder in einen funktionsfähigen Zustand versetzt werden. 

Cause

Bezüglich der Drittanbieter-Lizenzkomponente (Non-ATR) ist laut Flexera zu erwarten, dass Lizenzierungsprobleme auftreten, wenn sich die auf einem Rechner installierte Fuse-Version ändert. In ihren Anweisungen wird darauf hingewiesen, dass eine Neuinstallation des Lizenzierungsprozesses erforderlich ist. Da wir dies jedoch nicht eigenständig von Tableau Server aus tun können, ist eine komplette Neuinstallation die einzige Option. 
Lösung
Lösung: Führen Sie eine komplette Neuinstallation von Tableau Server durch, einschließlich der Lizenzierung, und stellen Sie die Daten aus einer Sicherung wieder her. 

Langfristige Lösung: Die ATR-Lizenzierung (Authorization To Run) des Servers wird durch Aktualisierungen der FUSE-Bibliothek nicht beeinträchtigt. Um proaktiv zu vermeiden, dass dieses Problem durch zukünftige FUSE-Bibliotheksupdates verursacht wird, implementieren Sie die Server-ATR-Lizenzierung bei der Neuinstallation oder beim nächsten geplanten Aktualisieren von Tableau Server auf eine neue Version. (Weitere Informationen finden Sie unter Verwenden eines Blue/Green-Ansatzes zur Aktualisierung von Tableau Server.)

Umgehung: Um künftige FUSE-Bibliotheks-Updates zu ermöglichen, ohne Server-ATR zu implementieren, können Sie in Abstimmung mit Ihrer IT-Abteilung neue Server-Hosts erstellen, auf denen die FUSE-Updates bereits installiert sind, wenn FUSE-Bibliotheks-Updates erforderlich sind. Migrieren Sie dann Ihren Tableau Server auf diese bereits aktualisierten Hosts. 
Zusätzliche Ressourcen

Dieses Problem identifizieren:

1. Prüfen Sie die Datei yum.log (RHEL-Systeme) oder dpkg.log (Debian), um zu sehen, ob Fuse-Bibliotheken seit der Installation von Tableau Server aktualisiert wurden.

Hinweis: Zum jetzigen Zeitpunkt sind nur Oracle Linux 7-Systeme von diesem Problem betroffen. Unter den weiterführenden Links auf dieser Seite finden Sie andere mögliche Probleme, falls dieses nicht vorliegt.

2. Darüber hinaus zeigen systemd-Protokolle (/var/log/messages oder /var/log/syslog) wiederholte Neustarts von FNP Licensing Service und TSM-Diensten:
 
Nov 09 14:50:20 o143006d systemd[5227]: Unit fnplicenseservice_0.service entered failed state. (Einheit fnplicenseservice_0.service hat einen Fehlerzustand angenommen.)
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service failed. (fnplicenseservice_0.service fehlgeschlagen.)
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service holdoff time over, scheduling restart. (fnplicenseservice_0.service Wartezeit abgelaufen, Neustart wird geplant.)
Nov 09 14:50:20 o143006d systemd[5227]: Stopped Tableau Server FNP Licensing Service. (Tableau Server FNP Licensing Service wurde angehalten.)

Dasselbe Protokoll wird schließlich Meldungen enthalten, die zeigen, dass FUSE fehlgeschlagen ist und beendet wurde:

Nov 09 14:50:20 o143006d FlexNetFs[19593]: Entering fuse_main (Eingabe in fuse_main)
Nov 09 14:50:20 o143006d FlexNetFs[19593]: Exited fuse_main - Failed (fuse_main beendet – Fehlgeschlagen)


Tableau Server nach Neustart des Betriebssystems unlizenziert
Tableau Server License Service auf Linux kann nach dem Neustart keine Lizenz lesen.

Nummer des Knowledge-Artikels

001474179

 
Laden
Salesforce Help | Article