Loading

Después de reiniciar el host del servidor, los comandos de TSM generan el error "No se pudo conectar al servidor; asegúrese de que Tableau Server esté en ejecución e inténtelo de nuevo"

Fecha de publicación: Dec 9, 2022
Descripción
En los sistemas Oracle Linux 7, cuando la máquina host de Tableau Server se reinicia después de actualizar la biblioteca FUSE en el sistema operativo, los comandos de TSM presentan el siguiente error:
 
"Could not connect to TSM Controller" (No se pudo establecer conexión con el controlador TSM).
"Could not connect to server. Make sure that Tableau Server is running and try again" (No se pudo conectar al servidor. Asegúrese de que Tableau Server esté en ejecución e inténtelo de nuevo).

Tableau Server puede volver a funcionar después de un tiempo. 

Cause

De acuerdo con el componente de licencia de terceros (no ATR), Flexera indicó que se espera que surjan problemas con las licencias si se modifica la versión de Fuse instalada en una máquina. En sus instrucciones, indican volver a ejecutar el proceso de licencias; pero, dado que no podemos hacerlo de forma independiente de Tableau Server, la única opción es llevar a cabo una reinstalación desde cero. 
Solución
Solución: ejecute una reinstalación de Tableau Server desde cero, incluidas las licencias, y restáurelo a partir de una copia de seguridad. 

Solución a largo plazo: las licencias de autorización de servidor para ejecutar (ATR) no se ven afectadas por las actualizaciones de la biblioteca FUSE. Para evitar de forma proactiva que este problema sea causado por futuras actualizaciones de la biblioteca FUSE,implemente licencias ATR del servidor cuando reinstale o planee actualizar Tableau Server a una nueva versión. (Consulte Usar un enfoque azul/verde para actualizar Tableau Server).

Solución: como solución alternativa para habilitar futuras actualizaciones de la biblioteca de FUSE sin implementar el ATR del servidor, trabaje con su departamento de TI y organice la creación de nuevos hosts de servidor con las actualizaciones de FUSE ya instaladas cuando se requieran actualizaciones de la biblioteca de FUSE y, a continuación, migre su Tableau Server de producción a esos hosts ya actualizados. 
Recursos adicionales

Para identificar este problema:

1. Revise el archivo yum.log (sistemas RHEL) o dpkg.log (Debian) para comprobar si las bibliotecas Fuse se actualizaron desde la instalación de Tableau Server.

Nota: Hasta ahora, solo los sistemas Oracle Linux 7 se encuentran afectados por este problema. Consulte la sección Enlaces relacionados en esta página para conocer otros posibles problemas si este no coincide con su búsqueda.

2. Además, los registros systemd (/var/log/messages o /var/log/syslog) muestran que el servicio de licencia de FNP y los servicios de TSM se reinician continuamente:
 
Nov 09 14:50:20 o143006d systemd[5227]: Unit fnplicenseservice_0.service entered failed state.
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service failed.
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service holdoff time over, scheduling restart.
Nov 09 14:50:20 o143006d systemd[5227]: Stopped Tableau Server FNP Licensing Service.

En el mismo registro, encontrará mensajes que muestran que Fuse presentó un error y se cerró:

Nov 09 14:50:20 o143006d FlexNetFs[19593]: Entering fuse_main
Nov 09 14:50:20 o143006d FlexNetFs[19593]: Exited fuse_main - Failed


Tableau Server sin licencia después de reiniciar el sistema operativo
El servicio de licencia de Tableau Server en Linux no puede leer la licencia tras un reinicio

Número del artículo de conocimiento

001474179

 
Cargando
Salesforce Help | Article