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Amazon Athena への接続試行時のエラー "Access Denied" (アクセスが拒否されました)

公開日: Aug 24, 2022
説明

Amazon Athena に接続しようとすると、エラーが発生します。

Unexpected Error (予期しないエラー)

[Simba][AthenaJDBC](100071) An error has been thrown from the AWS Athena client. com.amazonaws.services.s3.model.AmazonS3Exception: Access Denied (Service: Amazon S3; Status Code: 403; Error Code: AccessDenied; (AWS Athena クライアントからエラーがスローされました。... アクセスが拒否されました (サービス: Amazon S3、ステータス コード: 403、エラー コード: AccessDenied))

Error Code: E88DBC3B (エラー コード: E88DBC3B)

Cause

"アクセスが拒否されました" エラーは、Amazon Athena 側で問題が発生していることを示し、通常は以下の理由によって発生します。
  • AWS Identity and Access Management (IAM) ユーザーに、次の 1 つまたは複数のパーミッションがありません。
  • ソース データ バケットの読み取り
  • クエリ結果バケットへの結果の書き込み
  • Amazon Simple Storage Service (Amazon S3) バケット ポリシーで、必要なパーミッションが IAM ユーザーに付与されていません。
  • オブジェクトの所有者が Amazon S3 バケットの所有者と異なります。
  • 暗号化データの読み取りまたは書き込みに使用される AWS Key Management Service (AWS KMS) キーにアクセスできません。
  • AWS Glue Data Catalog ポリシーで、IAM ユーザーへのアクセスが許可されていません。
解決策
IT チームと連携して "アクセスが拒否されました" エラーのトラブルシューティングを行い、以下の点を確認します。
  • ソース データ バケットとクエリ結果バケットにアクセスするために必要なパーミッションが IAM ユーザーにあることを確認します。
  • クロスアカウント クエリに必要なパーミッションを Amazon S3 バケット ポリシーにアタッチします。
  • AWS KMS キーポリシーを更新します。
  • S3 バケットの所有者がオブジェクトにアクセスできることを確認します。
  • AWS Glue Data Catalog ポリシーで、IAM ユーザー/ロールへのアクセスが許可されていることを確認します。
ナレッジ記事番号

001474298

 
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