Loading

Error Code: 383490FC when connecting to Oracle

Date de publication: Feb 23, 2026
Description

After installing both the Oracle OCI and Essbase drivers for Tableau Desktop 2020.4, when connecting to Oracle in Tableau Desktop, the following error may occur:

An error occurred while communicating with Oracle
Bad Connection: Tableau could not connect to the data source
Error Code: 383490FC
Unable to connect to the Oracle server '
<server>. Check that the server is running and that you have access privileges to the requested database.

Cause

This error may occur when the driver for Oracle Essbase or other incompatible driver is installed.
Résolution
Try the following workarounds:

Option 1

Copy the attached oci.dll file to C:\Program Files\Tableau\Tableau 2020.4\bin and overwrite the oci.dll file in that folder.

Option 2

  1. Delete the oci.dll file in C:\Program Files\Tableau\Tableau 2020.4\bin
  2. Navigate to Control Panel\Programs\Programs and Features, right-click on the Tableau 2020.4 Oracle Driver in the list of programs, and select Repair.
  3. In the User Account Control dialog that appears, select Yes.

Option 3 

Install and use the JDBC driver
Numéro d’article de la base de connaissances

001474302

Pièces jointes

[DISALLOWED CONTENT REMOVED] oci.dll.txt

0 KB

 
Chargement
Salesforce Help | Article