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"[Hortonworks][Hardy] (71) Failed to establish connection with unknown error." occurs when using Custom SQL on Hortonworks Hadoop Hive

Publiceringsdatum: Mar 6, 2025
Beskrivning

When attempting to run a Custom SQL query to Hadoop Hive, the connection appears to be made, but data won't load into Tableau Desktop/Prep. Instead, the following error occurs: 
 

On Tableau Desktop:
 

"[Hortonworks][Hardy] (71) Failed to establish connection with unknown error."



On Tableau Prep: 
 

"system error"  or "[Hortonworks][Hardy] (71) Failed to establish connection with unknown error."

 

Cause

When bringing large dataset to Tableau Desktop/Prep, the Custom SQL reaches the limit of the query capacity. 

 

Lösning

Troubleshoot and determine if it's a Custom SQL issue by checking: 
 

  • Add "LIMIT 100" at the end of Custom SQL. 
  • Remove "WHERE" clauses 

 

If one of the steps above resolves the issue, you can use the following options:
 

Option 1Use materialized view.

A materialized view is a “SELECT query” with "JOIN, WHERE" performed on the database and the end result set is stored as a table in the database. The materialized view can be kept in sync with database updates. Instead of performing multiple joins, Tableau connects directly to the materialized view, allowing the database to perform the bulk of the processing of the initial query. 

 

Option 2: Optimize the Custom SQL.

If you still see the issue after applying a filter on Tableau Desktop, you may need to add more filters to reduce the data size.

  • Limit the fields/rows selected

 

Ytterligare resurser

Please note that this is NOT a connection issue and the above information should only be considered if the following conditions are met: 
1. Tableau Desktop/Prep can connect to Hortonworks Hadoop Hive without an issue 
2. It takes long time to run the Custom SQL outside of Tableau 

Knowledge-artikelnummer

001474358

 
Laddar
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