Loading

Error "Server's certificate does not match the URL" When Connecting to Tableau Server from Tableau Desktop

Udgivelsesdato: Apr 13, 2024
Beskrivelse

When trying to sign in Tableau Server from Tableau Desktop, an error occurs:

 

Cannot connect to Tableau Server. Please check the server name and port and try again

Server's certificate does not match the URL.

Cause

The SSL certificate on Tableau Server does not contain the Subject Alternative Name (SAN) extension. Starting from Tableau Desktop 2021.1, a security enhancement to adhere to current standards is introduced by Tableau. If the SAN in the SSL certificate is absent, the error will occur when trying to sign in Tableau Server.

Løsning

Upgrade to a newer, supported version of Tableau Desktop.

 

As a workaround if upgrading is not possible at this time, work with your IT team to verify that the domain, host name, or IP address that is being used to connect to Tableau Server is included in the Subject Alternative Name (SAN) field, then update your Tableau Server's SSL certificate accordingly.

Yderligere ressourcer
For more information, see Configure a Subject Alternative Name (SAN) certificate on Tableau Server.

The same error can occur in SAML login environment. If SAML authentication is used, the certificate of the Idp needs to be updated to include the Subject Alternative Name (SAN).
Vidensartikelnummer

001474434

 
Indlæser
Salesforce Help | Article