Loading

Sortierreihenfolge von berechnetem Feld wurde nach Ersetzen der veröffentlichten Datenquelle mit REST API geändert oder dupliziert

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung
Die manuelle Sortierreihenfolge eines berechneten Felds hat sich geändert oder wurde im Dialogfeld "Sortierungskonfiguration" geändert, nachdem die veröffentlichte Datenquelle mithilfe der REST API ersetzt wurde.
Vom Benutzer hinzugefügtes Bild

Cause

Dieses Verhalten ist ein bekanntes Problem mit der ID 1411816, das derzeit untersucht wird.
Lösung

Option 1

Ändern Sie in Tableau Desktop den Speicherort der Datenquelle mithilfe der heruntergeladenen .tsdx-Datei und veröffentlichen Sie sie anhand des folgenden Verfahrens:

    1. Laden Sie die veröffentlichte Datenquelle von Tableau Cloud herunter (.tdsx-Datei wird heruntergeladen).
    2. Öffnen Sie die im obigen Schritt 1 heruntergeladene Datei.
    3. Wählen Sie die Registerkarte "Datenquelle" aus.
    4. Wählen Sie das Dreiecksymbol des Datenquellennamens und dann "Verbindung bearbeiten" aus.
    5. Das Explorer-Fenster wird eingeblendet, in dem die neue Hyper-Datei ausgewählt wird. Klicken Sie dann in dem Fenster auf "Öffnen".
    6. Wählen Sie die Registerkarte "Blatt1" oder eine andere Registerkarte aus, jedoch nicht die Registerkarte "Datenquelle".
    7. Wählen Sie "Server" > "Datenquelle veröffentlichen" > "<Name der Datenquelle>" aus.
    8. Wählen Sie im Fenster "Datenquelle an Tableau Cloud veröffentlichen" das Zielprojekt und den Eingabenamen aus. Veröffentlichen Sie dann die Datenquelle, um die bestehende veröffentlichte Datenquelle zu ersetzen.
    9. Öffnen Sie die betroffene Ansicht und vergewissern Sie sich, dass die Sortierreihenfolge nicht geändert wurde und keine doppelten Felder vorhanden sind.

    Beachten Sie, dass eine erneute Veröffentlichung der neuen Hyper-Datei mit demselben Namen von Tableau Desktop nicht die Anzahl der Datensätze rendern kann, wenn diese in der Ansicht verwendet wird. 

Option 2

Verwenden Sie tabcmd mit der Option -o, um die Datenquelle oder den Datenextrakt zu überschreiben, falls bereits vorhanden.

Option 3

Löschen Sie die Sortierreihenfolge manuell und legen Sie erneut die manuelle Sortierreihenfolge fest. (Dies ist jedes Mal nötig, nachdem die Datenquelle mithilfe von REST API veröffentlicht wurde.)

Option 4

Aktualisieren Sie die Daten jedes Mal manuell, wenn Sie die Ansicht laden, indem Sie die Schaltfläche "Aktualisieren" auswählen, um die Ansicht temporär mit der korrekten (manuellen) Sortierreihenfolge zu rendern.
Vom Benutzer hinzugefügtes Bild



 
Nummer des Knowledge-Artikels

001474732

 
Laden
Salesforce Help | Article