Loading

El criterio de ordenación del campo calculado se modifica o duplica después de sustituir la fuente de datos publicada con la API de REST

Fecha de publicación: Dec 9, 2022
Descripción
El orden manual de un campo calculado cambió o se duplicó en el cuadro de diálogo de configuración Ordenar después de reemplazar la fuente de datos publicada mediante la API de REST.
Imagen añadida por un usuario

Cause

El comportamiento está relacionado con un problema conocido con el ID 1411816 que se encuentra en proceso de investigación.
Solución

Opción 1

Desde Tableau Desktop, cambie la ubicación de la fuente de datos con el archivo .tdsx descargado y, a continuación, publíquelo mediante el procedimiento que se indica a continuación:

    1. Descargue la fuente de datos publicada de Tableau Cloud (se descargará el archivo .tdsx).
    2. Abra la fuente de datos que descargó en el punto 1.
    3. Seleccione la pestaña "Fuente de datos".
    4. Seleccione el icono de triángulo hacia abajo del nombre de la fuente de datos y, a continuación, seleccione "Editar conexión".
    5. Cuando se muestre la ventana del explorador, seleccione el archivo .hyper nuevo. A continuación, haga clic en "Abrir" en la ventana.
    6. Seleccione la pestaña "Hoja1" u otra pestaña, excepto la pestaña "Fuente de datos".
    7. Seleccione "Servidor", "Publicar fuente de datos" y "<nombre de fuente de datos>".
    8. En la ventana "Publicar fuente de datos en Tableau Cloud", seleccione el proyecto de destino e ingrese el nombre. A continuación, publique la fuente de datos para reemplazar la fuente de datos publicada existente.
    9. Abra la vista afectada y confirme que el criterio de ordenación no haya cambiado ni que haya campos duplicados.

    Tenga en cuenta que al volver a publicar el archivo .hyper nuevo con el mismo nombre desde Tableau Desktop, es posible que no se muestre el campo Número de registros si se utiliza en la vista. 

Opción 2

Utilice el comando tabcmd con la opción -o para sobrescribir la fuente de datos o la extracción de datos si ya existe.

Opción 3

Elimine el criterio de ordenación de manera manual y establézcalo de nuevo (esto se debe hacer cada vez que se publique la fuente de datos mediante la API de REST).

Opción 4

Actualice los datos de manera manual cada vez que cargue la vista mediante el botón de actualización a fin de mostrar temporalmente la vista con el criterio de ordenación correcto (manual).
Imagen añadida por un usuario



 
Número del artículo de conocimiento

001474732

 
Cargando
Salesforce Help | Article