Loading

Menüs und Quickinfos in Dashboards, die in die Salesforce Lightning-Webkomponente eingebettet sind, funktionieren nur im Vollbildmodus.

Veröffentlichungsdatum: Nov 8, 2023
Beschreibung

In Salesforce eingebettete Berichte zeigen nur im Vollbildmodus Menüs oder Quickinfos an, unabhängig vom verwendeten Browser oder vom im Dashboard eingestellten Gerätelayout.

Cause

Dieses Problem wird derzeit unter Bekanntes Problem ID 1415835 untersucht.
Lösung

Option 1

Zeigen Sie die eingebettete Ansicht im Vollbild an.

Option 2

Deaktivieren Sie Lightning Web Security (LWS) vorübergehend.
  1. Melden Sie sich bei Ihrer Salesforce Lightning-Umgebung an. Beispiel: https://COMPANY.lightning.force.com/lightning/page/home.
  2. Klicken Sie auf das Zahnradsymbol in der oberen rechten Ecke.
  3. Klicken Sie auf Setup (Setup für die aktuelle Anwendung oder die Anwendung, in der sich das eingebettete Dashboard befindet).
  4. Klicken Sie im linken Menü auf Einstellungen > Sicherheit > Sicherheitseinstellungen. (Oder suchen Sie "Sitzungseinstellungen" in der Schnellsuche.)
  5. Suchen Sie die Einstellung Lightning Web Security und deaktivieren Sie die Option für Lightning Web Security für Lightning-Webkomponenten verwenden.
  6. Klicken Sie auf "Speichern".
  7. Melden Sie sich von Salesforce Lightning ab.
  8. Melden Sie sich erneut an – das Problem sollte nun behoben sein. Beachten Sie, dass es möglicherweise erforderlich ist, den Browser-Cache zu löschen.
Anleitungen zur Deaktivierung von LWS direkt in Salesforce finden Sie in der Salesforce-Dokumentation unter https://developer.salesforce.com/docs/component-library/documentation/en/lwc/lwc.security_lwsec_enable.
Nummer des Knowledge-Artikels

001475084

 
Laden
Salesforce Help | Article