Loading

Unable to verify the server's HTTPS certificate while running TSM commands

Fecha de publicación: Apr 25, 2025
Descripción

While running the TSM commands, it was giving the below error:

"Unable to verify the server's HTTPS certificate"


Also, tabadmincontroller was in error state.
Also from tabadminagent logs we can see below error:

20xx-xx-xx xx:0x:1xx.xxxx -0400  StatusRequestDispatcher-4-request : WARN  com.tableausoftware.service.status.HttpStatusFactory - IOException connecting to HTTP server at https://<hostname>:8850/actuator/health: Certificate for <hostname> doesn't match any of the subject alternative names: [hostname, FQDN]


 

Cause

Hostname of the computer has been changed due to which "localhost" breaks certificate validation when TSM CLI communicates with tabadmincontroller and the certificate validation fails.

Solución

There are two solutions:

Option 1
An alternate way to run the TSM commands would be to use the TSM commands by the below method:

  • When running "tsm command", specify FQDN name of Tableau Server.

For example:  tsm status -s https://<FQDN>:8850


Option 2

Work with the IT team to roll back the hostname change as it was before the issue started and once done, reboot the machine and verify the hostname again.

It will resolve the HTTP error.





 

Recursos adicionales
FQDN name means fully-qualified domain name (e.g. server123.mydomain.suffix) 
Número del artículo de conocimiento

001475188

 
Cargando
Salesforce Help | Article