Loading

Extract Refreshes of Flat Files (Excel, CSV) Fail When Using the "New Extract Refresh" Option to Create a Refresh Schedule

Date de publication: Apr 29, 2025
Description
When scheduling an extract refresh of an on-premises flat file (Excel, CSV, etc) using the "New Extract Refresh" option, the below error occurs.
 
Type [Data Source Name] of data source is not in the list of types allowed for refresh. Refresh skipped.

Or
An error occurred when refreshing extracts for the Datasource [DataSourceName]; Web Data Connector with URL [DataSourceName].csv is not in the list of allowed web data connectors or does not have the correct configuration. 

Cause

The "New Extract Refresh" option only works with cloud based databases and flat files.
Résolution
  1. Navigate to the affected data source, and from the Extract Refresh tab, remove any existing refresh schedules. 
  2. To set up a new Bridge (legacy) schedule, in the data source's actions menu, select Schedule with Bridge (Legacy), configure the schedule, and then click the Schedule Refresh button. See Set Up a Bridge Refresh Schedule for more information. 
Numéro d’article de la base de connaissances

001496556

 
Chargement
Salesforce Help | Article