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Error 401001 Occurs When Attempting to Authenticate Using the REST API With Personal Access Tokens

Publiseringsdato: Aug 25, 2025
Beskrivelse

When attempting to login to Tableau Cloud or Tableau Server using REST API with a Personal Access Token (PAT), the following error occurs:
 

<error code="401001">
<summary>Signin Error</summary>
<detail>Error signing in to Tableau Server</detail>

Cause

The PAT used in the authentication request is invalid. An invalid PAT could have several causes:

  • The PAT name or secret value is incorrect
  • The PAT has been revoked. A PAT may be revoked by the site user or by a Tableau Cloud or Tableau Server administrator.
  • The PAT has expired. PATs will expire if they are not used after 15 consecutive days. If they are used more frequently than every 15 days, their expiration depends on the PAT's site setting, which is configurable by a Tableau Cloud or Tableau Server administrator.

After PATs expire or are revoked, they're unable to be used for authentication and are removed from the user's My Account Settings page. The PAT secret can only be viewed at the time it is generated.

Løsning
  1. Verify the Personal Access Token is active and the PAT name and secret used with the REST API are accurate.
  2. If the PAT has expired or been revoked, or if it is not possible to verify that the PAT secret is correct, the user should create a new PAT and replace the old PAT name and secret with the new values in the login request. An administrator cannot create a PAT on behalf of a user.

Note: The error code 401001 is not a unique response to an invalid PAT, see the related documentation for the relevant authentication method if encountering this error when not using Personal Access Tokens.

For more information, see the error code reference in the REST API methods documentation: Authentication Methods - Sign In

Knowledge-artikkelnummer

001496614

 
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