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Gateway Fails to Start on Tableau Server After Enabling SSL When HTTP Uses Port 443

公開日: Jan 29, 2026
説明

When enabling SSL on Tableau Server, processes including the Gateway will fail to start if the HTTP port is already configured to use port 443.

 

One or more services failed to reach their expected state.
node1:
 flowprocessor_0.{build number}: Failed to start. Current status: STATUS_UNAVAILABLE
gateway_0.{build number}: Failed to start. Current status: DOWN

 

The following error occurs in the Gateway error.log:

You configured HTTP (80) on the standard HTTPS (443) port.

 

Cause

The issue occurs from a port conflict during the SSL enablement process.
When enabling SSL on Tableau Server, the Gateway uses port 443 for HTTPS traffic. If the Gateway already uses port 443 for HTTP traffic, Tableau Server attempts to bind both HTTP and HTTPS to the same port. This conflict prevents the Gateway service from starting.

解決策

To avoid this issue, temporarily disable SSL on Tableau Server. You can do this using the TSM Web UI or by running the following commands:

  • tsm configuration set -k ssl.enabled -v false
  • tsm pending-changes apply

 

To confirm the current Gateway port configuration, run this command:

  • tsm configuration get -k gateway.port

 

If the Gateway port for HTTP traffic is already configured to use the standard HTTPS port (443), follow these steps to resolve the issue:

  1. Change the Gateway port to a non-443 port, such as 80, 8000, or 8080. For more details, see Change the Default Gateway Port from 80.
  2. After updating the Gateway port, reconfigure SSL on Tableau Server. For more details, see Configure SSL for Tableau Server.
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ナレッジ記事番号

001496615

 
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Salesforce Help | Article