Loading
Salesforce now sends email only from verified domains. Read More

Synchronising large groups fails with error "Unavailable Critical Extension (errorCode=100012)"

Publish Date: Apr 29, 2025
Description

Synchronizing large groups (1600+ members) fails with error "Unavailable Critical Extension (errorCode=100012)"
The issue is intermittent. For instance, scheduler cannot complete the operation, but manual synchronization successfully completes.
 

Cause

This is due to large default retrieval size that is 1500. The default value of 1500 is a limitation on the Active Directory controller and a smaller value is required for large groups.
 
Resolution
To mitigate the problem, configure the retrieval size by using the wgserver.domain.ldap.members.retrieval.page.size setting:

                tsm stop
                tsm configuration set -k wgserver.domain.ldap.members.retrieval.page.size -v 500
                tsm pending-changes apply
                tsm start
               
 
Additional Resources
Knowledge Article Number

001496637

 
Loading
Salesforce Help | Article