Loading

Fehler "Die von uns berechnete Anfragesignatur stimmt nicht mit der von Ihnen angegebenen Signatur überein" beim Verbinden mit Athena, wenn der Server Großbuchstaben enthält

Veröffentlichungsdatum: Oct 3, 2022
Beschreibung

Beim Versuch, eine Verbindung zu einem Athena-Extrakt, der eine Serveradresse mit Großbuchstaben verwendet, herzustellen oder diesen zu aktualisieren, tritt der folgende Fehler auf: 


TableauException: [JDBC Driver]The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details. (Service: AmazonAthena; Status Code: 400; Error Code: InvalidSignatureException; Request ID: [...]) System error. (Tableau-Ausnahme: [JDBC-Treiber]Die von uns berechnete Anforderungssignatur stimmt nicht mit der von Ihnen angegebenen Signatur überein. Überprüfen Sie Ihren geheimen AWS-Zugriffsschlüssel und die Signiermethode. Einzelheiten finden Sie in der Service-Dokumentation. (Dienst: AmazonAthena; Statuscode: 400; Fehlercode: InvalidSignatureException; Anforderungs-ID: [...]) Systemfehler.)

Cause

Eine Änderung auf der Athena-Seite erfordert, dass die Serveradresse in Kleinbuchstaben angegeben wird.
Lösung
Option 1: Ändern Sie den Server (Athena.eu-west-1.amazonaws.com), sodass dieser mit einem Kleinbuchstaben beginnt (athena.eu-west-1.amazonaws.com).

Option 2: Ändern Sie den Server (Athena.eu-west-1.amazonaws.com), sodass die Region enthalten ist (athena.eu-west-1.amazonaws.com;AwsRegion=eu-west-1;)
Zusätzliche Ressourcen
Wenn Sie Ihren Zugriffsschlüssel vor kurzem geändert haben oder zum ersten Mal versuchen, ihn zu aktualisieren, handelt es sich möglicherweise um ein Sonderzeichen. Weitere Informationen finden Sie im folgenden KB-Artikel: Fehler "The request signature we calculated does not match the signature you provided." (Die von uns berechnete Anforderungssignatur stimmt nicht mit der von Ihnen angegebenen Signatur überein.) bei der Verbindung mit Amazon Athena

Community-Post: https://community.tableau.com/s/question/0D78b0000098XcUCAU/detail
Nummer des Knowledge-Artikels

001496883

 
Laden
Salesforce Help | Article