Loading

Error “La firma de solicitud que calculamos no coincide con la firma que proporcionó” en la conexión a Athena cuando el servidor contiene letras en mayúscula

Fecha de publicación: Oct 3, 2022
Descripción

Al intentar conectar o actualizar un extracto de Athena que utiliza una dirección de servidor que contiene letras en mayúscula, se produce el siguiente error: 


TableauException: [JDBC Driver] The request signature we calculated does not match the signature you provided. (TableauException: [Controlador JDBC] La firma de solicitud que calculamos no coincide con la firma que proporcionó). Compruebe su clave de acceso secreta de AWS y el método de firma. Consulte la documentación del servicio para obtener más información. (Servicio: AmazonAthena; Código de estado: 400; Código de error: InvalidSignatureException; ID de solicitud: [...]) Error del sistema.

Cause

Un cambio en Athena requiere que la dirección del servidor esté en minúsculas.
Solución
Opción 1 Cambie el servidor (Athena.eu-west-1.amazonaws.com) para que comience con una letra en minúscula (athena.eu-west-1.amazonaws.com)

Opción 2 Cambie el servidor (Athena.eu-west-1.amazonaws.com) para que incluya la región (athena.eu-west-1.amazonaws.com;AwsRegion=eu-west-1;)
Recursos adicionales
Si recientemente cambió su clave de acceso o si es la primera vez que intenta actualizar, es posible que se trate de un carácter especial. Consulte el siguiente artículo de la KB: La firma de solicitud que calculamos no coincide con la firma que proporcionó. Al conectarse a Amazon Athena

Entrada de la comunidad: https://community.tableau.com/s/question/0D78b0000098XcUCAU/detail
Número del artículo de conocimiento

001496883

 
Cargando
Salesforce Help | Article