Loading

Fehler: "Unable to connect to data source with the supplied credentials, or no credentials provided." bei Direktverbindung oder Aktualisieren eines OneDrive- (veraltet), OneDrive- und SharePoint Online-, Dropbox- oder Google Drive-Extrakts

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung
Wenn Sie versuchen, auf eine Live-Datenquelle zuzugreifen oder einen Extrakt mit OneDrive (veraltet), OneDrive und SharePoint Online, Dropbox oder Google Drive zu aktualisieren, nachdem zuvor mehrere Verbindungen erfolgreich waren, tritt der folgende Fehler auf:
 
Unable to connect to data source with the supplied credentials, or no credentials provided. Tableau needs an unexpired OAuth refresh token to connect to the data. Ask your database administrator to issue a refresh token, then try again. You must log in to Dropbox to perform this request. (Mit den angegebenen Anmeldeinformationen kann keine Verbindung zur Datenquelle hergestellt werden bzw. es wurden keine Anmeldeinformationen bereitgestellt. Tableau benötigt ein aktuelles OAuth-Aktualisierungstoken, um eine Verbindung mit den Daten herzustellen. Bitten Sie Ihren Datenbankadministrator, ein Aktualisierungstoken auszustellen, und versuchen Sie es erneut. Sie müssen sich bei Dropbox anmelden, um diese Anfrage durchzuführen.)

Cause

In Tableau 2022.3 wurden Backend-Änderungen an der OAuth-Verarbeitung vorgenommen, die eine erneute Authentifizierung bei diesen Datenquellen erfordern.
Lösung
Um das Problem zu beheben, melden Sie sich bei der Datenquelle an, wenn Sie dazu aufgefordert werden, oder löschen Sie die gespeicherten Anmeldeinformationen manuell und fügen Sie sie unter Ihren Kontoeinstellungen erneut hinzu. Unter normalen Umständen sollte dies eine einmalige Korrektur sein. Weitere Informationen finden Sie unter Gespeicherte Anmeldeinformationen für Datenverbindungen verwalten.
Nummer des Knowledge-Artikels

001496915

 
Laden
Salesforce Help | Article