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Tableau Error "Error Code: 06DA155A [Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection..." Connecting to Azure Synapse Analytics

Julkaisupäivä: Apr 13, 2024
Kuvaus

Can not connect to Azure Synapse Analytics server due to TCP related error below:

An error occurred while communicating with Azure Synapse Analytics
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.
Error Code: 06DA155A
[Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection because an error was encountered during handshakes before login. Common causes include client attempting to connect to an unsupported version of SQL Server, server too busy to accept new connections or a resource limitation (memory or maximum allowed connections) on the server.
[Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection
[Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection due to prelogin failure
Unable to connect to the Azure Synapse Analytics server "<server name or ip address>". Check that the server is running and that you have access privileges to the requested database.

Cause

Environmental - Network
The "TCP" error indicates that there is a network connection issue between Tableau Desktop or Tableau Server and the Azure Synapse Analytics server.
Ratkaisu
Work with your IT network team to configure the network setting to access Azure Synapse Analytics server.
Check that your firewall allows outgoing TCP communication on TCP port 1433, since the SQL Azure Database / Azure Synapse Analytics service is only available with TCP port 1433
For more troubleshooting information, please refer to the Microsoft document Azure SQL Database and Azure Synapse IP firewall rules - Troubleshoot the database firewall .
 
Lisäresurssit
There is a simple way to check if you have a network issue to access Azure Synapse Analytics server out of the Tableau side. Try to connect the Azure Synapse Analytics sever from the Tableau Desktop Client PC with Excel to see if the connecting works well or not. For more details, please refer to the Microsoft document below:
Connect Excel to a database in Azure SQL Database or Azure SQL Managed Instance, and create a report
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001497077

 
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