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Aktualisierung von Schemas, die mit ODBC Netsuite auf Tableau Cloud verbunden sind, kann nicht durchgeführt werden

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Schemas, die über ODBC Netsuite verbunden sind, können nicht aktualisiert werden:

Es kann keine Verbindung mit dem Remote-Datenbankserver in Verbindung NetSuite(ODBC) hergestellt werden.

Cause

Derzeit wird eine direkte Verbindung von Tableau Cloud zu NetSuite nicht unterstützt.
Lösung
Installieren Sie zur Umgehung des Problems Tableau Bridge auf einem dedizierten Computer und legen Sie einen Aktualisierungszeitplan für die ODBC NetSuite-Datenquelle über Bridge fest. Damit Tableau Bridge eine Verbindung zur Datenquelle herstellen und die Daten auf dem neuesten Stand halten kann, muss die Datenquelle separat in Tableau Cloud veröffentlicht werden.

1. Stellen Sie in der neuesten Version von Tableau Desktop eine Verbindung zu einer NetSuite-Datenquelle her. 
a. Gehen Sie zu https://www.tableau.com/de-de/support/drivers und suchen Sie 'Oracle NetSuite'. 
b. Laden Sie die .jar-Datei für das Windows-Betriebssystem herunter und legen Sie sie in C:\Programme\Tableau\Drivers ab.
c. Starten Sie Tableau Desktop v2022.2 oder neuer und wählen Sie den NetSuite-Connector aus.
d. Versuchen Sie, eine Verbindung zur Datenquelle herzustellen.  Wenn der NetSuite-Connector nicht funktioniert, versuchen Sie es mit dem Connector "Andere Datenbank (ODBC)" und testen Sie die Verbindung erneut.
 
Sobald die Verbindung erfolgreich hergestellt wurde, fahren Sie mit den nächsten Schritten fort. 

2. Erstellen Sie einen Extrakt und veröffentlichen Sie ihn in Tableau Cloud.
a. Wählen Sie dieselbe Tabelle aus, die für das Schema verwendet wird.
b. Schalten Sie das Optionsfeld in der oberen rechten Ecke von "Live" zu "Extrakt" um. Sie werden aufgefordert, den Extrakt zu speichern. Der Speicherort spielt keine Rolle, also speichern Sie ihn am Standardspeicherort.
c. Wechseln Sie zu 'Blatt 1' und wählen Sie das Menü Server aus.  Klicken Sie auf Datenquelle veröffentlichen.
d. Wählen Sie im Dialogfeld "Datenquelle veröffentlichen" die Schaltfläche Bearbeiten aus und betten Sie unter "Authentifizierung" das Kennwort für die Datenquelle ein.
e. Klicken Sie auf Veröffentlichen.

3. Erstellen Sie einen Zeitplan für die neue Extraktaktualisierung für diese veröffentlichte Datenquelle.
Sobald der Veröffentlichungsprozess abgeschlossen ist, werden Sie automatisch zur veröffentlichten Datenquelle auf Tableau Cloud weitergeleitet.
a. Wählen Sie die Registerkarte Verbindungen aus, klicken Sie auf ... und wählen Sie unter "Aktionen" die Option Verbindung bearbeiten aus.
b. Wählen Sie Privatnetzwerk als Netzwerktyp aus und speichern Sie.
c. Gehen Sie zur Registerkarte Extraktaktualisierungen und wählen Sie die Schaltfläche Neue Extraktaktualisierung aus, um einen Zeitplan zu erstellen.  Speichern Sie den neuen Zeitplan.  

4. Öffnen Sie das Schema in Tableau Prep Builder und ersetzen Sie die NetSuite-Eingangsverbindung durch eine veröffentlichte NetSuite-Datenquelle.
a. Klicken Sie auf +, um eine Verbindung hinzuzufügen.
b. Wählen Sie Tableau Server aus und melden Sie sich bei Ihrer Tableau Cloud-Site an, falls noch nicht geschehen.
c. Suchen Sie im Dialogfeld Nach Daten suchen die veröffentlichte NetSuite-Datenquelle in der Liste und klicken Sie dann auf die Schaltfläche Verbinden.
d. Klicken Sie mit der rechten Maustaste auf die ursprüngliche Eingabe, NetSuite, und klicken Sie dann auf Entfernen.
e. Ziehen Sie das Eingabefeld für die veröffentlichte Datenquelle auf den Beginn (Hinzufügen) der bestehenden Schritte.

5. Veröffentlichen Sie das Schema erneut und geben Sie es (als veröffentlichte Datenquelle) in Prep Builder aus.

6. Versuchen Sie, das neu veröffentlichte Schema auszuführen.
a. Navigieren Sie in Tableau Cloud zum neu veröffentlichten Schema.
b. Klicken Sie auf Geplante Aufgabe und wählen Sie dann die Schaltfläche Neue Aufgabe aus, um einen Zeitplan für die Ausführung dieses Schemas zu erstellen.
c. Klicken Sie auf ... und wählen Sie unter "Aktionen" die Option Jetzt ausführen.
d. Gehen Sie zur Seite "Aufträge", um den Status dieses Auftrags zu sehen und zu prüfen, ob er erfolgreich ist.
Nummer des Knowledge-Artikels

001497161

 
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