Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

Tableau Server の Tableau Prep Conductor プロセス ステータスが使用不可になる

公開日: Mar 18, 2026
説明

Tableau Prep Conductor プロセスが使用不可状態になります。flowprocessor_0 がライセンス情報を読み取ることができないためです。 

"tsm status -v" コマンドを実行すると、次が表示されることがあります。

Status:DEGRADED" and Tableau Prep Conductor 0' status is unavailable.(ステータス: DEGRADED" および Tableau Prep Conductor 0' ステータスを使用できません)

 

原因

この既知の問題に対する解決策は、こちらに記載のとおり、導入済みです。 

解決策

この既知の問題に対する解決策は、こちらに記載のとおり、導入済みです。 

 

この問題の影響を受けるバージョンを使用している場合は、次の方法を試してください。


Linux:
tsm stop
sudo /opt/tableau/tableau_server/packages/scripts./stop-administrative-services
sudo /opt/tableau/tableau_server/packages/scripts./start-administrative-services
tsm start

Windows:
tsm stop

cd C:\Program Files\Tableau\Tableau Server\packages\scripts.
stop-administrative-services
start-administrative-services

tsm start


マルチノード環境で問題が発生した場合は、OS を再起動 (および stop-administrative-services と start-administrative-services を実行) します。その後、tsm topology set-process を使用して flowprocessor のプロセスをアンインストールし、再インストールします。次の手順を参照してください。


1. flowprocessor をアンインストールするには、flowprocessor のノードロールを no-flows に変更します。
例:
tsm topology set-node-role -n node1, node2 -r no-flows

2. flowproecssor をインストールするために、flowproecssor がないノードにバックグラウンダーを追加します。
例:
tsm topology set-process -n node3 -pr backgrounder -c 1

3. 保留中の変更を適用します。

4. no-flows ノードロールを all-jobs に変更して、flowprocessor を再インストールします。
例:
tsm topology set-node-role -n node1,node2 -r all-jobs

5. ステップ 2 のノードからバックグラウンダーを削除します。
例:
tsm topology set-process -n node3 -pr backgrounder -c 0

6. 保留中の変更を適用します。

その他のリソース

この問題を確認するには、次の flowprocessor ログを確認します:  INFO com.tableausoftware.tabadmin.agent.status.ServiceStatusRequestRunner - Posting status update for flowprocessor_0:STATUS_UNAVAILABLE, detail message:License check did not succeed for flowprocessor_0 (INFO com.tableausoftware.tabadmin.agent.status.ServiceStatusRequestRunner - flowprocessor_0 のステータス更新を送信しています:STATUS_UNAVAILABLE,詳細メッセージ:flowprocessor_0 のライセンスチェックに失敗しました)

Tableau Prep フロー作成 (ログの場所)

ナレッジ記事番号

001497254

 
読み込み中
Salesforce Help | Article