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Embedded BigQuery Extract Fails with Resolution Details "Check the Data Connection page for necessary updates to an access token or embedded credentials"

Date de publication: Feb 20, 2025
Description

The extract refresh for a Google BigQuery data source that is embedded in a published workbook may fail with the following resolution details in the notifications for the failed refresh jobs:

Check the Data Connection page for necessary updates to an access token or embedded credentials.

Cause

The Google BigQuery saved credentials under the workbook owner's Account Settings in Tableau Cloud are missing or expired.
Résolution
The owner of the published workbook should carry out the following steps:

Step 1. Add the saved credentials for the BigQuery connection to the Tableau Cloud Account Settings page:
a. Sign in to Tableau Cloud in a browser.
b. At the top of a page, click your profile image or initials, select My Account Settings, and then scroll down to the Saved Credentials for Data Sources section.
c. If there is a saved credential under Google BigQuery, click 'Delete' and delete the credential.
d. Next to Google BigQuery, click 'Add' and add the Google BigQuery credential.

Step 2. Check the data sources embedded in the workbook:
a. In Tableau Cloud, navigate to the page for the affected workbook, and select the Data Sources tab.
b. Next to the data source, select the Actions button (...) > Edit Connection.
c. In the Edit Connection dialog box, ensure that 'Embedded credentials in the connection' is selected, and a Google BigQuery credential is selected in the drop-down menu.
d. If any changes were made, click 'Save' to save the changes.
Numéro d’article de la base de connaissances

001498182

 
Chargement
Salesforce Help | Article