Loading

"System error: null" Occurs When Running an Existing Flow and the Output Filename Contains Non-English Characters

Date de publication: Jan 21, 2025
Description

​After upgrading Tableau Server to the May 2023 maintenance release or Tableau Cloud 2023.2.0 (20232.23.0701.0006), the "System error: null" occurs when running an existing flow which contains non-English characters, such as Chinese, Japanese or Korean in the Output filename.

If you publish a new flow with CJK characters in Output, the flow is published successfully but running it on Tableau Server will cause the above error. 
 

Cause

This behavior is related to a known issue with Reference ID W-13541386 that is now fixed.

Résolution

NOTE: This issue has been fixed in Tableau Cloud as of July 20, 2023

Option 1: Upgrade to Tableau Server version 2023.1.5 or later


Option 2: Remove non-English characters from output file names. 

1. Open the published existing flow that contains non-English characters in Output name on Tableau Server.
User-added image
2. Select Edit Flow.
3. Change the output name and remove any non-English characters and publish the flow. 
User-added image

4. Re-run the flow. A new output/data source will be created with the new name. This is a new data source that is not connected to an existing workbook.
5. Open the existing affected workbook on Tableau Server and select Edit
6. Open the Data Source tab on the bottom left. Click Select to select a new output/data source with a non-English name. 
User-added image
7. Publish the workbook. It will be reconnected to the new data source

 

Ressources supplémentaires
The existing workbooks can still be browsed on Tableau Server but the data may be stale due to the flow failure.

How to find the Tableau Cloud Version 
Numéro d’article de la base de connaissances

001498230

 
Chargement
Salesforce Help | Article