Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

既存のフローを実行し、出力ファイル名に英語以外の文字が含まれていると "System error: null (システム エラー: null)" が発生する

公開日: Sep 25, 2023
説明

​Tableau Server を 2023 年 5 月のメンテナンス リリースまたは Tableau Cloud 2023.2.0 (20232.23.0701.0006) にアップグレードした後、中国語、日本語、韓国語などの英語以外の文字が出力ファイル名に含まれている既存のフローを実行すると "System error: null (システム エラー: null)" が発生します。

CJK 文字が出力に含まれる新しいフローをパブリッシュした場合、フローは正常にパブリッシュされますが、Tableau Server で実行すると上記のエラーが発生します。 
 

Cause

この動作は、修正された既知の問題 (リファレンス ID W-13541386) に関連しています。
解決策

オプション 1: Tableau Server を次のいずれかのバージョンにアップグレードします。

  • Tableau Server 2023.1.5
  • Tableau Server 2022.3.9
  • Tableau Server 2022.1.17
  • Tableau Server 2021.4.21
  • Tableau Server 2021.3.26
注: この問題は、2023 年 7 月 20 日現在、Tableau Cloud で修正されています



オプション 2: 出力ファイル名から英語以外の文字を削除します。 

1. Tableau Server で、英語以外の文字が出力名に含まれているパブリッシュ済みの既存のフローを開きます。
ユーザーが追加した画像
2. [フローの編集] を選択します。
3. 出力名を変更し、英語以外の文字を削除してフローをパブリッシュします。 
ユーザーが追加した画像

4. フローを再実行します。新しい出力/データ ソースが新しい名前で作成されます。これは、既存のワークブックに接続されていない新しいデータ ソースです。
5. Tableau Server 上の既存のワークブックで影響を受けるものを開き、[編集] を選択します。 
6. 左下の [データ ソース] タブを開きます。[選択] をクリックして、英語以外の名前の新しい出力/データ ソースを選択します。 
ユーザーが追加した画像
7. ワークブックをパブリッシュします。新しいデータ ソースに再接続されます。 

 

その他のリソース
既存のワークブックは引き続き Tableau Server で参照できますが、フローの失敗のためデータが古くなっている場合があります。

Tableau Cloud のバージョンの確認方法
ナレッジ記事番号

001498230

 
読み込み中
Salesforce Help | Article