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Protokolle, die mit "tsm maintenance send-logs" oder der Option "In technischen Support hochladen" in TSM gesendet werden, werden nicht an Tableau gesendet

Veröffentlichungsdatum: Jan 10, 2024
Beschreibung

In Tableau Server 2022.3 und neuer werden Protokolle, die mit dem Befehl "tsm maintenance send-logs" oder der Schaltfläche "In technischen Support hochladen" in der TSM-Web-Benutzeroberfläche gesendet werden, nicht wie erwartet an den Tableau-Supportfall gesendet.  

In TSM treten keine Fehler auf und der Auftrag wird als erfolgreich angezeigt.

Cause

Dieses Problem wird derzeit untersucht und kann auf der Salesforce-Website für bekannte Probleme unter der Referenz-ID W-13073139 eingesehen werden.
Lösung

Option A

Ändern Sie den Schlüssel "features.RemoveDoubleEncryption" auf "false".  Beachten Sie, dass die Anwendung dieser Änderung einen Neustart von Tableau Server erfordert.

1. Führen Sie tsm configuration set -k features.RemoveDoubleEncryption -v false aus.
2. Führen Sie tsm pending-changes list aus.
3. Nachdem Sie bestätigt haben, dass die Änderung an "features.RemoveDoubleEncryption" die einzige ausstehende Änderung ist, führen Sie tsm pending-changes apply aus.

Nachdem Sie diese Einstellung geändert haben, sollten die Protokolle wieder in den Supportfällen angezeigt werden.

Option B

Führen Sie den Befehl "send-logs" manuell aus, wobei das Flag "RemoveDoubleEncryption" deaktiviert ist.  Diese Option ist wesentlich komplizierter, erfordert aber keinen Neustart von Tableau Server.

1. Führen Sie tsm maintenance send-logs -f <log file location> -e <email> -c <case number> aus.
2. Suchen Sie in der Datei tabadmincontroller_node#-#.log nach dem entsprechenden tabcrashreporter-Befehl.  Der Protokolleintrag sieht in etwa wie folgt aus: 

LINUX:

Launching tabcrashreporter.exe with the following command: "/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption

WINDOWS:

Launching tabcrashreporter.exe with the following command: "D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption


3. Entfernen Sie den Befehl aus der Protokollzeile und ändern Sie "--enable-features RemoveDoubleEncryption" zu "--disable-features RemoveDoubleEncryption".
4. Führen Sie in einem Terminal-Fenster den resultierenden Befehl aus, der in etwa so aussehen sollte wie in den folgenden Beispielen.  Beachten Sie, dass es sich hier um EINEN sehr langen Befehl handelt und nicht um mehrere Befehle:

LINUX:

"/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption

WINDOWS:

"D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption

Nummer des Knowledge-Artikels

001498234

 
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