Loading

Los registros enviados mediante "tsm maintenance send-logs" o la opción Cargar a soporte técnico en TSM no se envían a Tableau

Fecha de publicación: Jan 10, 2024
Descripción

En Tableau Server 2022.3 y versiones posteriores, los registros enviados mediante el comando "tsm maintenance send-logs" o el botón "Cargar en soporte técnico" de la interfaz de usuario web de TSM no se envían al caso de soporte de Tableau como se esperaba.  

No hay errores en TSM y el trabajo se muestra como correcto.

Cause

Se está investigando este problema y se puede ver desde el sitio web de problemas conocidos de Salesforce con el ID de referencia W-13073139.
Solución

Opción A

Cambie la configuración de la clave features.RemoveDoubleEncryption a "false".  Tenga en cuenta que, para aplicar este cambio, deberá reiniciar Tableau Server.

1. Ejecute tsm configuration set -k features.RemoveDoubleEncryption -v false.
2. Ejecute tsm pending-changes list.
3. Después de confirmar que el cambio en features.RemoveDoubleEncryption es el único cambio pendiente, ejecute tsm pendent-changes apply.

Después de cambiar esta configuración, los registros deberían comenzar a aparecer nuevamente en los casos de soporte.

Opción B

Ejecute el comando send-logs manualmente con el indicador RemoveDoubleEncryption desactivado.  Esta opción es considerablemente más complicada, pero no requiere reiniciar Tableau Server.

1. Ejecute tsm maintenance send-logs -f <log file location> -e <email> -c <case number>.
2. Busque en el archivo tabadmincontroller_node#-#.log el comando tabcrashreporter equivalente.  La entrada de registro tendrá un aspecto similar al siguiente: 

LINUX:

Launching tabcrashreporter.exe with the following command: "/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption

WINDOWS:

Launching tabcrashreporter.exe with the following command: "D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption


3. Quite el comando de la línea de registro y cambie "--enable-features RemoveDoubleEncryption" por "--disable-features RemoveDoubleEncryption".
4. En una ventana Terminal, ejecute el comando resultante, que debería ser similar a los siguientes ejemplos.  Tenga en cuenta que este es UN SOLO comando muy largo, en comparación con una colección de comandos:

LINUX:

"/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption

WINDOWS:

"D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption

Número del artículo de conocimiento

001498234

 
Cargando
Salesforce Help | Article