Loading

El conector de OneDrive se retiró y los flujos no se pueden conectar o actualizar, y se muestra el error "Tableau no reconoce el tipo de fuente de datos "cloudfile:onedrive-excel-direct" "

Fecha de publicación: Jun 1, 2023
Descripción
Los libros de trabajo, fuentes de datos y flujos existentes no se conectan o no se actualizan, y se muestra el siguiente mensaje de error:
 
Tableau doesn't recognize the data source type 'cloudfile:onedrive-excel-direct'. It might not be available in this version of Tableau, or it might be a connector plugin that's not installed on this system (Tableau no reconoce el tipo de fuente de datos "cloudfile:onedrive-excel-direct". Puede que no esté disponible en esta versión de Tableau o que un complemento del conector no esté instalado en este sistema).

Cause

Se retirará el conector de OneDrive, que quedó obsoleto en Tableau 2022.2 y se eliminó de Tableau 2023.2.

Consulte el artículo de la base de conocimientos de Tableau que indica que el conector de OneDrive quedó obsoleto en 2022.2.
Solución
Abra el libro de trabajo, la fuente de datos o el flujo existente en una versión anterior a la versión 2023.2 de Tableau Desktop o Tableau Prep Builder, y realice los pasos que se enumeran a continuación para reemplazar las fuentes de datos. Esto puede requerir la descarga de su libro de trabajo, fuente de datos o flujo existente desde Tableau Cloud si es ahí donde están publicados.

Tableau Desktop

1. Abra su libro de trabajo o fuente de datos.
2. Añada una nueva fuente de datos (Datos > Nueva fuente de datos) y seleccione el conector de OneDrive y SharePoint Online.
3. Conéctese al mismo archivo que se usa en el libro de trabajo o fuente de datos existente.
4. Reemplace las fuentes de datos (Datos > Reemplazar fuentes de datos).
5. Cierre la fuente de datos original según el conector de OneDrive eliminado.
6. Guarde y vuelva a publicar su libro de trabajo o fuente de datos.

Tableau Prep Builder

1. Abra su flujo.
2. Añada una nueva conexión mediante el conector de OneDrive y SharePoint Online.
3. Conéctese al mismo archivo que se usa en el flujo existente.
4. Reemplace los nodos de entrada originales con los mismos del conector de OneDrive y SharePoint Online.
5. Quite la conexión original de OneDrive (obsoleta).
6. Guarde su flujo y publíquelo de nuevo.

Número del artículo de conocimiento

001498248

 
Cargando
Salesforce Help | Article