Loading

Fehler "Gateway timeout. Check to make sure the server is running" (Gateway-Zeitüberschreitung. Stellen Sie sicher, dass der Server ausgeführt wird.) beim Erstellen einer lokalen Datenquellenkopie

Veröffentlichungsdatum: Aug 24, 2022
Beschreibung
Beim Erstellen einer lokalen Kopie einer Datenquelle in Tableau Desktop tritt der folgende Fehler auf:
Gateway timeout. Check to make sure the server is running (Gateway-Zeitüberschreitung. Stellen Sie sicher, dass der Server ausgeführt wird.)

Beim Versuch, direkt von Tableau Server herunterzuladen, scheint der Befehl erfolgreich ausgeführt zu werden, es wird jedoch ein leerer Bildschirm angezeigt.

Cause

Bei einem Netzwerkgerät, wie z. B. einem Lastausgleich oder einem Proxyserver, kam es zu einer Zeitüberschreitung und die Verbindung wurde getrennt. 
Lösung
Erhöhen Sie die Zeitüberschreitung des Lastausgleichs oder Proxyservers, um die Gateway-Zeitüberschreitung zu vermeiden.
Zusätzliche Ressourcen
Sie können überprüfen, ob die Proxy-Zeitüberschreitung das Problem ist, indem Sie den Proxyserver umgehen, um die Daten herunterzuladen:
  1. ​Verwenden Sie Remote Desktop, um eine Verbindung zu dem Computer herzustellen, auf dem Tableau Server ausgeführt wird.
  2. Navigieren Sie zu 127.0.0.1 und führen Sie eine Authentifizierung mit Tableau Server durch.
  3. Versuchen Sie, die Datenquelle herunterzuladen.

Wenn dies erfolgreich ist, weist dies darauf hin, dass ein Problem bei der Aufrechterhaltung der Netzwerkverbindung zwischen den Client-Computern und Tableau Server besteht.

Beim Herunterladen über "localhost" oder die IP-Adresse 127.0.0.1 kommt die Anfrage von dem Computer, auf dem Tableau Server ausgeführt wird, und stellt eine direkte Verbindung zu den Daten her, ohne die Umgebung des Computers zu verlassen. Das erfolgreiche Herunterladen in diesem Szenario beweist, dass weder mit den Daten (sie sind nicht beschädigt) noch mit Tableau Server (es handelt sich nicht um ein Berechtigungs- oder Konfigurationsproblem) etwas nicht stimmt.

Beim Herunterladen über "tableau.mycompany.com" kommt die Anfrage vom Client-Computer, geht zu einem Netzwerkgerät (Router, Firewall, Switch usw.) und wird dann mit Tableau Server verbunden. Beim Versuch, die Datei herunterzuladen, meldet das Netzwerkgerät, dass die Verbindung zu lange dauert, und trennt sie nach Erreichen der Zeitüberschreitung mit dem Fehler HTTP 504. Andere Datenquellen sind möglicherweise nicht betroffen, da sie heruntergeladen werden, bevor das Zeitüberschreitungslimit erreicht ist.

Nummer des Knowledge-Artikels

001498348

 
Laden
Salesforce Help | Article