Loading

Error "Gateway timeout. Check to make sure the server is running" al crear una copia local de la fuente de datos

Fecha de publicación: Aug 24, 2022
Descripción
Al crear una copia local de una fuente de datos en Tableau Desktop, se produce el siguiente error:
Gateway timeout. Check to make sure the server is running (Se agotó el tiempo de espera de la puerta de enlace. Asegúrese de que el servidor se esté ejecutando).

Al intentar descargar directamente desde Tableau Server, el comando parece ejecutarse con éxito, aunque presenta una pantalla en blanco.

Cause

Se está agotando el tiempo de espera de un dispositivo de red, como un equilibrador de carga o un servidor proxy, y se está cerrando la conexión. 
Solución
Para evitar que se agote el tiempo de espera de la puerta de enlace, aumente el tiempo de espera del equilibrador de carga o del servidor proxy.
Recursos adicionales
Puede confirmar si el problema es que se agota el tiempo de espera del proxy. Para ello, omita el servidor proxy a fin de descargar los datos:
  1. ​Use el escritorio remoto para conectarse al equipo donde se ejecuta Tableau Server.
  2. Vaya a 127.0.0.1 y autentíquese con Tableau Server.
  3. Intente descargar la fuente de datos.

Si lo logra, quiere decir que hay un problema con el mantenimiento de una conexión de red entre los equipos cliente y Tableau Server.

Al descargar mediante el "localhost" o la IP 127.0.0.1, la solicitud proviene del equipo donde se ejecuta Tableau Server y se conecta directamente a los datos sin salir del entorno del equipo. Si la descarga se completa correctamente en este escenario, significa que no hay ningún problema con los datos (no están dañados) ni con Tableau Server (no es un problema de permisos ni de configuración).

Al descargar mediante "tableau.mycompany.com", la solicitud proviene del equipo cliente, se dirige al dispositivo de red (router, firewall, conmutador, etc.) y luego se conecta a Tableau Server. Al intentar la descarga, el dispositivo de red indica que la conexión está tardando demasiado y la interrumpe después de agotar el tiempo de espera, lo cual genera el error HTTP 504. Puede que otras fuentes de datos no se vean afectadas, ya que se descargan antes de llegar al límite del tiempo de espera.

Número del artículo de conocimiento

001498348

 
Cargando
Salesforce Help | Article