Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

データ ソースのローカル コピーを作成するときのエラー "Gateway timeout. Check to make sure the server is running" (ゲートウェイ タイムアウト。サーバーが実行中であることを確認してください)

公開日: Aug 24, 2022
説明
Tableau Desktop でデータ ソースのローカル コピーを作成するときに、次のエラーが発生します。
Gateway timeout. Check to make sure the server is running (ゲートウェイ タイムアウト。サーバーが実行されていることを確認してください)

Tableau Server から直接ダウンロードしようとすると、コマンドは正常に実行されたように見えますが、画面には何も表示されません。

Cause

ロード バランサやプロキシ サーバーなどのネットワーク デバイスがタイムアウトして接続を閉じています。 
解決策
ロード バランサまたはプロキシ サーバーのタイムアウトを延長して、ゲートウェイのタイムアウトを回避します。
その他のリソース
プロキシ サーバーをバイパスしてデータをダウンロードすることで、プロキシ タイムアウトが問題であるかどうかを確認できます。
  1. ​リモート デスクトップを使用して、Tableau Server を実行しているコンピューターに接続します。
  2. 127.0.0.1 にアクセスし、Tableau Server で認証します。
  3. データ ソースのダウンロードを試みます。

成功した場合、これは、クライアント コンピューターと Tableau Server 間のネットワーク接続の維持に問題があることを示しています。

"localhost" または IP 127.0.0.1 からダウンロードする場合、要求は Tableau Server を実行しているコンピューターから送信され、コンピューターの環境の外に出ることなくデータに直接接続します。 このシナリオで正常にダウンロードされれば、データまたは Tableau Server には何の問題もない (データは破損しておらず、パーミッションまたは構成の問題でもない) ことの証明になります。

"tableau.mycompany.com" からダウンロードする場合、要求はクライアント コンピューターから送信され、ネットワーク デバイス (ルーター、ファイアウォール、スイッチなど) を経由して Tableau Server に接続します。ダウンロードを試みると、接続に時間がかかりすぎているという応答がネットワーク デバイスから返され、タイムアウト時間の経過後に接続が切断されて、HTTP 504 エラーがスローされます。データ ソースによっては、タイムアウトの制限に達する前にダウンロードされるため、影響を受けない場合があります。

ナレッジ記事番号

001498348

 
読み込み中
Salesforce Help | Article