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Errores intermitentes "Unable to Sign In" y "Invalid Username or Password" al iniciar sesión usando SAML

Fecha de publicación: Aug 24, 2022
Descripción
Cuando los usuarios intentan iniciar sesión en Tableau Server, se producen los siguientes errores de forma intermitente, aunque se haya podido realizar la autenticación correctamente antes:
  • Unable to sign in (No puede iniciar sesión). 
  • Invalid username or password (Nombre de usuario o contraseña no válidos)
Además, se puede encontrar lo siguiente en el registro de VizPortal:
com.tableausoftware.api.webclient.remoting.AuthenticatedUserParameterProvider - WebClient: called API method has parameter of IAuthenticatedUser type, but when called there was no logged in user. Responding with 'InvalidSessionException' (com.tableausoftware.api.webclient.remoting.AuthenticatedUserParameterProvider - WebClient: el método API solicitado tiene el tipo de parámetro IAuthenticatedUser pero, cuando se le solicita, no hay ningún usuario con la sesión iniciada. Responder con 'InvalidSessionException')

Cause

La sesión de autenticación en el IdP sigue siendo válida, pero la sesión en Tableau Server ha vencido.
Solución
Compruebe que la configuración de duración máxima de la sesión en el IdP de SAML coincida con la configuración de wgserver.saml.maxauthenticationage en Tableau Server. La configuración predeterminada en Tableau Server es de 7200 segundos o 2 horas. 
Número del artículo de conocimiento

001498357

 
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