Loading

Errori intermittenti "Unable to Sign In" e "Invalid Username or Password" durante l'accesso tramite SAML

Data pubblicazione: Aug 24, 2022
Descrizione
Quando gli utenti tentano di accedere a Tableau Server, si verificano in modo intermittente i seguenti errori, anche se l'autenticazione ha avuto esito positivo in precedenza:
  • Unable to sign in. (Impossibile accedere.)
  • Invalid username or password. (Nome utente o password non validi.)
Inoltre, il seguente errore può essere presente nel log di VizPortal:
com.tableausoftware.api.webclient.remoting.AuthenticatedUserParameterProvider - WebClient: called API method has parameter of IAuthenticatedUser type, but when called there was no logged in user. Responding with 'InvalidSessionException'

Cause

La sessione di autenticazione sull'IdP è ancora valida, ma la sessione su Tableau Server è scaduta.
Risoluzione
Assicurati che l'impostazione per la validità massima della sessione nell'IdP SAML corrisponda all'impostazione wgserver.saml.maxauthenticationage in Tableau Server. L'impostazione predefinita in Tableau Server è 7200 secondi o 2 ore. 
Numero articolo Knowledge

001498357

 
Caricamento
Salesforce Help | Article