Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

SAML を使用してログインするときの一時的なエラー "Unable to Sign In" および "Invalid Username or Password"

公開日: Aug 24, 2022
説明
ユーザーが Tableau Server にログインしようとすると、それまでは認証に成功していたにもかかわらず次のエラーが断続的に発生します。
  • Unable to sign in. (サインインできません。)
  • Invalid username or password. (ユーザー名またはパスワードが無効です。)
さらに、VizPortal ログに次のように記録されます。
com.tableausoftware.api.webclient.remoting.AuthenticatedUserParameterProvider - WebClient: called API method has parameter of IAuthenticatedUser type, but when called there was no logged in user. Responding with 'InvalidSessionException' (com.tableausoftware.api.webclient.remoting.AuthenticatedUserParameterProvider - WebClient: 呼び出した API メソッドに IAuthenticatedUser タイプのパラメーターがありますが、呼び出し時にログインしていたユーザーがいませんでした。'InvalidSessionException' による応答)

Cause

IdP の認証セッションはまだ有効ですが、Tableau Server のセッションの有効期限が切れています。
解決策
SAML IdP のセッションの最大有効期限の設定が Tableau Server の wgserver.saml.maxauthenticationage 設定と一致していることを確認します。Tableau Server のデフォルトの設定は 7200 秒か 2 時間です。
ナレッジ記事番号

001498357

 
読み込み中
Salesforce Help | Article