Loading

Fehler "Unable to Sign In. User account not found" nach dem Konfigurieren von SAML auf Tableau Server

Veröffentlichungsdatum: Apr 28, 2023
Beschreibung
Nachdem Tableau für die SAML-Authentifizierung konfiguriert wurde, können sich Benutzer nicht mehr anmelden, und die folgenden Fehler treten auf:

Unable to Sign In (Anmeldung nicht möglich)
User account not found (Benutzerkonto nicht gefunden)

 

Cause

Der vom IdP gesendete "username"-Wert stimmt nicht mit dem "username" von Tableau Server oder Tableau Cloud überein.
Lösung
Stellen Sie sicher, dass der vom Identitätsanbieter (IdP) an Tableau Server oder Tableau Cloud gesendete Wert "username" exakt mit dem "username" in Tableau Server oder Tableau Cloud übereinstimmt.

Zum Beispiel muss für den untenstehenden Benutzer der vom IdP gesendete "username"-Wert "test" lauten, nicht "test user" oder "test@test.com"
 
Vom Benutzer hinzugefügtes Bild

Wenn der Wert "username" auf der IdP-Seite nicht mit dem "username" für Tableau Server oder Tableau Cloud übereinstimmt, sollten Sie eine der folgenden Optionen in Betracht ziehen, um die Werte aufeinander abzustimmen.

Option 1

Wenn ein anderer Wert als "username" auf dem IdP mit "username" von Tableau Server übereinstimmt,

beispielsweise wenn der Anzeigename mit dem "username" von Tableau Server übereinstimmt, können Sie eine der folgenden Aktionen durchführen:

Bei Tableau Server für Windows Version 2018.2 und neuer oder bei Tableau Server für Linux:

Legen Sie eine Attributregel auf dem IdP fest, um den Anzeigenamenwert als "username" zu senden.
  • Verwenden Sie TSM, um Tableau Server anzuweisen, "displayname" als "username" auszuwerten. Dies kann auf der TSM-Benutzeroberfläche erledigt werden, wie unter Schritt 5 der SAML-Einstellungen in Konfigurieren der serverweiten SAML beschrieben.
  • Dies kann auch in der TSM-CLI erledigt werden, indem Sie den folgenden Befehl über eine als Administrator geöffnete cmd-Eingabeaufforderung ausführen:
tsm authentication saml map-asssertions --user-name displayname
Hinweis: Bei diesem Befehl wird die Groß-/Kleinschreibung beachtet. Daher müssen Sie den Attributnamen genau so angeben, wie er auf dem IdP angezeigt wird. Lautet das IdP-Attribut beispielsweise "DisplayName", müssen Sie im TSM-Befehl DisplayName verwenden und nicht displayname.

Bei Tableau Server für Windows Versionen 2018.1 und früher:

Verwenden Sie "tabdmin", um Tableau Server anzuweisen, "displayname" als "username" auszuwerten:
  1. Öffnen Sie als Administrator eine Eingabeaufforderung.
  2. Navigieren Sie zum Tableau Server-Ordner "bin", der sich standardmäßig unter C:\Program Files\Tableau\Tableau Server\<version>\bin befindet, und geben Sie den folgenden Befehl ein:
    tabadmin set wgserver.saml.idpattribute.username displayname

    Hinweis: Bei diesem Befehl wird die Groß-/Kleinschreibung beachtet. Daher müssen Sie den Attributnamen genau so angeben, wie er auf dem IdP angezeigt wird. Lautet das IdP-Attribut beispielsweise "DisplayName", müssen Sie DisplayName im Befehl "tabadmin set" verwenden und nicht displayname.

Option 2

Liegt auf der IdP-Seite kein Wert vor, der mit "username" von Tableau Server oder Tableau Cloud übereinstimmt, oder wenn es nicht möglich ist, Änderungen am IdP vorzunehmen,

  • ändern Sie die "username"-Werte in Tableau Server oder Tableau Cloud so, dass sie mit dem übereinstimmen, was der IdP senden kann.
Zusätzliche Ressourcen

Wenn sich Benutzer auf nicht standardmäßigen Domänen befinden, muss im Wert "username" dieser Benutzer das Domänenpräfix enthalten sein.
Nummer des Knowledge-Artikels

001498392

 
Laden
Salesforce Help | Article